# CVE-2025-54136: Cursor's Modification of MCP Server Definitions Bypasses Manual Re-approvals

> Attackers can achieve remote code execution by silently modifying trusted MCP server configurations in shared repositories or locally, bypassing security re-approval prompts.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2025
- **Updated:** 4 Aug 2025

## What is CVE-2025-54136?

CVE-2025-54136 is a high-severity code injection vulnerability in cursor, published on 1 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Cursor is a code editor built for programming with AI. In versions 1.2.4 and below, attackers can achieve remote and persistent code execution by modifying an already trusted MCP configuration file inside a shared GitHub repository or editing the file locally on the target's machine. Once a collaborator accepts a harmless MCP, the attacker can silently swap it for a malicious command (e.g., calc.exe) without triggering any warning or re-prompt. If an attacker has write permissions on a user's active branches of a source repository that contains existing MCP servers the user has previously approved, or allows an attacker has arbitrary file-write locally, the attacker can achieve arbitrary code execution. This is fixed in version 1.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-54136?

It affects 1 product.


Products: Anysphere Cursor.

## How do I fix CVE-2025-54136?

No fix has been published for CVE-2025-54136 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54136 being exploited?

There is no known exploitation of CVE-2025-54136 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-54136 PoC (github_poc): https://github.com/PRE5T0/CVE-2025-54136
- A lightweight mcp to prevent poisoning CVE (CVE-2025-54136), researchers hijacking Claude Code/Copilot/Gemini via prompt injection, and hundreds of MCP servers exposed with zero auth, this mcp protects the individual developer's laptop, where most MCP servers actually run. (github_poc): https://github.com/Sushank05/mcp-doorman
- Free security-baseline rule for Claude Code, Codex, and Cursor: treats MCP tool descriptions as untrusted input (OWASP MCP Top 10 MCP03, CVE-2025-54136). (github_poc): https://github.com/GeeksikhSecurity/ai-tool-poisoning-guard

## Other vulnerabilities in cursor

- [CVE-2026-50548](https://insights.sbomify.com/CVE-2026-50548/): Cursor Desktop sandbox escape via agent-controlled working directory (critical 9.3)
- [CVE-2026-50549](https://insights.sbomify.com/CVE-2026-50549/): Cursor Desktop sandbox escape via symlink and failed path canonicalization (critical 9.3)
- [CVE-2025-64106](https://insights.sbomify.com/CVE-2025-64106/): Cursor: Speedbump Modal Bypass in MCP Server Deep-Link (high 8.8)
- [CVE-2025-64107](https://insights.sbomify.com/CVE-2025-64107/): Cursor is Vulnerable to Path Manipulation Using Backslashes on Windows (high 8.8)
- [CVE-2025-64108](https://insights.sbomify.com/CVE-2025-64108/): Cursor's Sensitive File Modification can Lead to NTFS Path Quirks (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54136 and fix it if it is affected.

What it is: CVE-2025-54136 is a high-severity code injection vulnerability in cursor, published on 1 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54136 in the wild and no public exploit code.

Affected product: cursor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54136/ (Markdown: https://insights.sbomify.com/CVE-2025-54136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54136
- OSV: https://osv.dev/vulnerability/CVE-2025-54136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54136/
Summaries are generated and may contain mistakes; the official description above is the record.
