# CVE-2025-54137: NodeJS version of the HAX CMS application is distributed with Default Secrets

> Unauthenticated attackers can use hardcoded default credentials and JWT keys to access and modify HAX CMS instances.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-5fpv-5qvh-7cf3

## What is CVE-2025-54137?

CVE-2025-54137 is a high-severity vulnerability in haxtheweb issues, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAX CMS NodeJS allows users to manage their microsite universe with a NodeJS backend. Versions 11.0.9 and below were distributed with hardcoded default credentials for the user and superuser accounts. Additionally, the application has default private keys for JWTs. Users aren't prompted to change credentials or secrets during installation, and there is no way to change them through the UI. An unauthenticated attacker can read the default user credentials and JWT private keys from the public haxtheweb GitHub repositories. These credentials and keys can be used to access unconfigured self-hosted instances of the application, modify sites, and perform further attacks. This is fixed in version 11.0.10.

Weakness: CWE-1392 (Use of Default Credentials)

## Which versions are affected by CVE-2025-54137?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.10 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.10 |

Products: Psu Haxcms-Nodejs.

## How do I fix CVE-2025-54137?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.10 or later.

## Is CVE-2025-54137 being exploited?

There is no known exploitation of CVE-2025-54137 in the wild and no public exploit code.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54137 and fix it if it is affected.

What it is: CVE-2025-54137 is a high-severity vulnerability in haxtheweb issues, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54137 in the wild and no public exploit code.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.10
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54137/ (Markdown: https://insights.sbomify.com/CVE-2025-54137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54137
- OSV: https://osv.dev/vulnerability/CVE-2025-54137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54137/
Summaries are generated and may contain mistakes; the official description above is the record.
