# CVE-2025-54138: LibreNMS has Authenticated Local File Inclusion in ajax_form.php that Allows RCE

> Authenticated attackers can achieve remote code execution in LibreNMS via local file inclusion in ajax_form.php due to lack of input validation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-gq96-8w38-hhj2

## What is CVE-2025-54138?

CVE-2025-54138 is a high-severity code injection vulnerability in Librenms Librenms, published on 22 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems. LibreNMS versions 25.6.0 and below contain an architectural vulnerability in the ajax_form.php endpoint that permits Remote File Inclusion based on user-controlled POST input. The application directly uses the type parameter to dynamically include .inc.php files from the trusted path includes/html/forms/, without validation or allowlisting. This pattern introduces a latent Remote Code Execution (RCE) vector if an attacker can stage a file in this include path — for example, via symlink, development misconfiguration, or chained vulnerabilities. This is fixed in version 25.7.0.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2025-54138?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 25.7.0 |
| `librenms/librenms` | Packagist | All versions | 25.7.0 |

Products: Librenms Librenms.

## How do I fix CVE-2025-54138?

Upgrade librenms/librenms to 25.7.0 or later.

## Is CVE-2025-54138 being exploited?

There is no known exploitation of CVE-2025-54138 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54138 and fix it if it is affected.

What it is: CVE-2025-54138 is a high-severity code injection vulnerability in Librenms Librenms, published on 22 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54138 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 25.7.0
- librenms/librenms (Packagist): affected all versions; fixed in 25.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54138/ (Markdown: https://insights.sbomify.com/CVE-2025-54138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54138
- OSV: https://osv.dev/vulnerability/CVE-2025-54138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54138/
Summaries are generated and may contain mistakes; the official description above is the record.
