CVE-2025-54139 HAX CMS' application pages are vulnerable to clickjacking
Attackers can perform clickjacking attacks on HAX CMS pages due to missing security headers, potentially coercing users into unintended actions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-54139?
CVE-2025-54139 is a medium-severity vulnerability in haxtheweb issues, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
HAX CMS allows users to manage their microsite universe with a NodeJS or PHP backend. In haxcms-nodejs versions 11.0.12 and below and in haxcms-php versions 11.0.7 and below, all pages within the HAX CMS application do not contain headers to prevent other websites from loading the site within an iframe. This applies to both the CMS and generated sites. An unauthenticated attacker can load the standalone login page or other sensitive functionality within an iframe, performing a UI redressing attack (clickjacking). This can be used to perform social engineering attacks to attempt to coerce users into performing unintended actions within the HAX CMS application. This is fixed in haxcms-nodejs version 11.0.13 and haxcms-php 11.0.8.
Weakness: CWE-1021
Which versions are affected by CVE-2025-54139?
4 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs and elmsln/haxcms. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@haxtheweb/haxcms-nodejs npm | All versions | 11.0.13 |
@haxtheweb/haxcms-nodejs npm | All versions | 11.0.13 |
elmsln/haxcms Packagist | All versions | 11.0.8 |
elmsln/haxcms Packagist | All versions | 11.0.8 |
Products include Psu Haxcms-Nodejs, Psu Haxcms-Php.
How do I fix CVE-2025-54139?
Upgrade @haxtheweb/haxcms-nodejs to 11.0.13 or later.
Is CVE-2025-54139 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54139 exists.
Other vulnerabilities in haxtheweb issues
- CVE-2025-54127 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access
- CVE-2025-49141 HaxCMS-PHP Command Injection Vulnerability
- CVE-2025-49137 Hax CMS Stored Cross-Site Scripting vulnerability
- CVE-2025-54378 HAX CMS Backend Lacks Comprehensive Authorization Checks
- CVE-2026-22704 HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover
Sources
Also known as GHSA-54vw-f4xf-f92j.