# CVE-2025-54140: pyLoad has Path Traversal Vulnerability in json/upload Endpoint that allows Arbitrary File Write

> Authenticated attackers can write arbitrary files via path traversal in pyLoad, potentially leading to remote code execution and privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-xqpg-92fq-grfg, PYSEC-2026-1823

## What is CVE-2025-54140?

CVE-2025-54140 is a high-severity path traversal vulnerability in pyload, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyLoad is a free and open-source Download Manager written in pure Python. In version 0.5.0b3.dev89, an authenticated path traversal vulnerability exists in the /json/upload endpoint of pyLoad. By manipulating the filename of an uploaded file, an attacker can traverse out of the intended upload directory, allowing them to write arbitrary files to any location on the system accessible to the pyLoad process. This may lead to: Remote Code Execution (RCE), local privilege escalation, system-wide compromise, persistence, and backdoors. This is fixed in version 0.5.0b3.dev90.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-54140?

3 open source packages ship an affected version, including pyload-ng.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | From 0.5.0b3.dev89 | 0.5.0b3.dev90 |
| `pyload-ng` | PyPI | From 0.5.0b3.dev89 | 0.5.0b3.dev90 |
| `pyload-ng` | PyPI | From 0.5.0b3.dev89 | 0.5.0b3.dev90 |

## How do I fix CVE-2025-54140?

Upgrade pyload-ng to 0.5.0b3.dev90 or later.

## Is CVE-2025-54140 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54140 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54140 and fix it if it is affected.

What it is: CVE-2025-54140 is a high-severity path traversal vulnerability in pyload, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54140 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected from 0.5.0b3.dev89; fixed in 0.5.0b3.dev90
- pyload-ng (PyPI): affected from 0.5.0b3.dev89; fixed in 0.5.0b3.dev90
- pyload-ng (PyPI): affected from 0.5.0b3.dev89; fixed in 0.5.0b3.dev90

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54140/ (Markdown: https://insights.sbomify.com/CVE-2025-54140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54140
- OSV: https://osv.dev/vulnerability/CVE-2025-54140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54140/
Summaries are generated and may contain mistakes; the official description above is the record.
