# CVE-2025-54264: Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

> High-privileged attackers can inject malicious scripts into Adobe Commerce form fields, leading to session takeover when victims view the page.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Oct 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-2768-5wmv-cfff

## What is CVE-2025-54264?

CVE-2025-54264 is a high-severity cross-site scripting vulnerability in Adobe Commerce, published on 14 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Adobe Commerce versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by a stored Cross-Site Scripting (XSS) Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality, and integrity impact to high. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field. Scope is changed.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-54264?

12 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | 2.4.6-p13 |
| `magento/community-edition` | Packagist | All versions | 2.4.6-p13 |
| `magento/community-edition` | Packagist | From 2.4.7-beta1 | 2.4.7-p8 |
| `magento/community-edition` | Packagist | From 2.4.7-beta1 | 2.4.7-p8 |
| `magento/community-edition` | Packagist | From 2.4.8-beta1 | 2.4.8-p3 |
| `magento/community-edition` | Packagist | From 2.4.8-beta1 | 2.4.8-p3 |
| `magento/community-edition` | Packagist | From 2.4.9-alpha1 | 2.4.9-alpha3 |
| `magento/community-edition` | Packagist | From 2.4.9-alpha1 | 2.4.9-alpha3 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce, Adobe Commerce B2b, Adobe Magento.

## How do I fix CVE-2025-54264?

Upgrade magento/community-edition to a fixed version for your release line: 2.4.6-p13, 2.4.7-p8, 2.4.8-p3 or 2.4.9-alpha3.

## Is CVE-2025-54264 being exploited?

There is no known exploitation of CVE-2025-54264 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54264 and fix it if it is affected.

What it is: CVE-2025-54264 is a high-severity cross-site scripting vulnerability in Adobe Commerce, published on 14 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-54264 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.6-p13
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.6-p13
- magento/community-edition (Packagist): affected from 2.4.7-beta1; fixed in 2.4.7-p8
- magento/community-edition (Packagist): affected from 2.4.7-beta1; fixed in 2.4.7-p8
- magento/community-edition (Packagist): affected from 2.4.8-beta1; fixed in 2.4.8-p3
- magento/community-edition (Packagist): affected from 2.4.8-beta1; fixed in 2.4.8-p3
- magento/community-edition (Packagist): affected from 2.4.9-alpha1; fixed in 2.4.9-alpha3
- magento/community-edition (Packagist): affected from 2.4.9-alpha1; fixed in 2.4.9-alpha3
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54264/ (Markdown: https://insights.sbomify.com/CVE-2025-54264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54264
- OSV: https://osv.dev/vulnerability/CVE-2025-54264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54264/
Summaries are generated and may contain mistakes; the official description above is the record.
