CVE-2025-54286 CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI
Attackers can create and start LXD containers without consent via CSRF when client certificate authentication is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-54286?
CVE-2025-54286 is a high-severity vulnerability in Canonical LXD, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-Site Request Forgery (CSRF) in LXD-UI in Canonical LXD versions >= 5.0 on Linux allows an attacker to create and start container instances without user consent via crafted HTML form submissions exploiting client certificate authentication.
Weakness: CWE-352
Which versions are affected by CVE-2025-54286?
9 open source packages ship an affected version, including github.com/canonical/lxd. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/canonical/lxd Go | All versions | None |
github.com/canonical/lxd Go | From 0.0.0-20220401034332-1e1349e3cbf3 | 0.0.0-20250827065555-0494f5d47e41 |
github.com/canonical/lxd Go | From 0.0.0-20220401034332-1e1349e3cbf3 | 0.0.0-20250827065555-0494f5d47e41 |
github.com/canonical/lxd Go | From 5.0 | 5.0.5 |
github.com/canonical/lxd Go | From 5.0 | 5.0.5 |
github.com/canonical/lxd Go | From 5.1 | 5.21.4 |
3 more packages
github.com/canonical/lxd Go | From 5.1 | 5.21.4 |
github.com/canonical/lxd Go | From 6.0 | 6.5 |
github.com/canonical/lxd Go | From 6.0 | 6.5 |
Products include Canonical Lxd.
How do I fix CVE-2025-54286?
Upgrade github.com/canonical/lxd to a fixed version for your release line: 0.0.0-20250827065555-0494f5d47e41, 5.0.5, 5.21.4 or 6.5.
Is CVE-2025-54286 being exploited?
There is no known exploitation of CVE-2025-54286 in the wild and no public exploit code.
Other vulnerabilities in Canonical LXD
- CVE-2026-66897 Instance template path traversal allows arbitrary host file write as root
- CVE-2026-62420 Cross-project cluster migration bypasses project restrictions via cluster notification flag
- CVE-2026-63293 Arbitrary File Read/Write: metadata.yaml symlink in image allows host filesystem access as root
- CVE-2026-63294 Root RCE via image backup.yaml symlink
- CVE-2026-63296 Project restriction bypass via instance migration config override
Sources
Also known as DEBIAN-CVE-2025-54286, GHSA-p8hw-rfjg-689h, GO-2025-4003.