# CVE-2025-54286: CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI

> Attackers can create and start LXD containers without consent via CSRF when client certificate authentication is enabled.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2025
- **Updated:** 26 Feb 2026
- **Also known as:** DEBIAN-CVE-2025-54286, GHSA-p8hw-rfjg-689h, GO-2025-4003

## What is CVE-2025-54286?

CVE-2025-54286 is a high-severity vulnerability in Canonical LXD, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) in LXD-UI in Canonical LXD versions >= 5.0 on Linux allows an attacker to create and start container instances without user consent via crafted HTML form submissions exploiting client certificate authentication.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-54286?

9 open source packages ship an affected version, including github.com/canonical/lxd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/canonical/lxd` | Go | All versions | None |
| `github.com/canonical/lxd` | Go | From 0.0.0-20220401034332-1e1349e3cbf3 | 0.0.0-20250827065555-0494f5d47e41 |
| `github.com/canonical/lxd` | Go | From 0.0.0-20220401034332-1e1349e3cbf3 | 0.0.0-20250827065555-0494f5d47e41 |
| `github.com/canonical/lxd` | Go | From 5.0 | 5.0.5 |
| `github.com/canonical/lxd` | Go | From 5.0 | 5.0.5 |
| `github.com/canonical/lxd` | Go | From 5.1 | 5.21.4 |
| `github.com/canonical/lxd` | Go | From 5.1 | 5.21.4 |
| `github.com/canonical/lxd` | Go | From 6.0 | 6.5 |
| `github.com/canonical/lxd` | Go | From 6.0 | 6.5 |

Products: Canonical Lxd.

## How do I fix CVE-2025-54286?

Upgrade github.com/canonical/lxd to a fixed version for your release line: 0.0.0-20250827065555-0494f5d47e41, 5.0.5, 5.21.4 or 6.5.

## Is CVE-2025-54286 being exploited?

There is no known exploitation of CVE-2025-54286 in the wild and no public exploit code.

## Other vulnerabilities in Canonical LXD

- [CVE-2026-66897](https://insights.sbomify.com/CVE-2026-66897/): Instance template path traversal allows arbitrary host file write as root (critical 9.9)
- [CVE-2026-62420](https://insights.sbomify.com/CVE-2026-62420/): Cross-project cluster migration bypasses project restrictions via cluster notification flag (critical 9.9)
- [CVE-2026-63293](https://insights.sbomify.com/CVE-2026-63293/): Arbitrary File Read/Write: metadata.yaml symlink in image allows host filesystem access as root (critical 9.9)
- [CVE-2026-63294](https://insights.sbomify.com/CVE-2026-63294/): Root RCE via image backup.yaml symlink (critical 9.9)
- [CVE-2026-63296](https://insights.sbomify.com/CVE-2026-63296/): Project restriction bypass via instance migration config override (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54286 and fix it if it is affected.

What it is: CVE-2025-54286 is a high-severity vulnerability in Canonical LXD, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-54286 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/canonical/lxd (Go): affected all versions; no fix listed
- github.com/canonical/lxd (Go): affected from 0.0.0-20220401034332-1e1349e3cbf3; fixed in 0.0.0-20250827065555-0494f5d47e41
- github.com/canonical/lxd (Go): affected from 0.0.0-20220401034332-1e1349e3cbf3; fixed in 0.0.0-20250827065555-0494f5d47e41
- github.com/canonical/lxd (Go): affected from 5.0; fixed in 5.0.5
- github.com/canonical/lxd (Go): affected from 5.0; fixed in 5.0.5
- github.com/canonical/lxd (Go): affected from 5.1; fixed in 5.21.4
- github.com/canonical/lxd (Go): affected from 5.1; fixed in 5.21.4
- github.com/canonical/lxd (Go): affected from 6.0; fixed in 6.5
- github.com/canonical/lxd (Go): affected from 6.0; fixed in 6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54286/ (Markdown: https://insights.sbomify.com/CVE-2025-54286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54286
- OSV: https://osv.dev/vulnerability/CVE-2025-54286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54286/
Summaries are generated and may contain mistakes; the official description above is the record.
