CVE-2025-54291 Project existence disclosure in LXD images API

Medium 6.9 Published Updated

Unauthenticated attackers can determine project existence in LXD via differing HTTP status codes in the images API.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54291?

CVE-2025-54291 is a medium-severity vulnerability in Canonical LXD, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Information disclosure in images API in Canonical LXD before 6.5 and 5.21.4 on all platforms allows unauthenticated remote attackers to determine project existence via differing HTTP status code responses.

Weakness: CWE-209

Which versions are affected by CVE-2025-54291?

7 open source packages ship an affected version, including github.com/canonical/lxd. It affects 1 product.

PackageAffectedFixed in
github.com/canonical/lxd GoFrom 0.0.0-20200331193331-03aab09f5b5c0.0.0-20250827065555-0494f5d47e41
github.com/canonical/lxd GoFrom 0.0.0-20200331193331-03aab09f5b5c0.0.0-20250827065555-0494f5d47e41
github.com/canonical/lxd GoFrom 0.0.0-20200331193331-03aab09f5b5c0.0.0-20250827065555-0494f5d47e41
github.com/canonical/lxd GoFrom 4.05.21.4
github.com/canonical/lxd GoFrom 4.05.21.4
github.com/canonical/lxd GoFrom 6.06.5
1 more packages
github.com/canonical/lxd GoFrom 6.06.5

Products include Canonical Lxd.

How do I fix CVE-2025-54291?

Upgrade github.com/canonical/lxd to a fixed version for your release line: 0.0.0-20250827065555-0494f5d47e41, 5.21.4 or 6.5.

Is CVE-2025-54291 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54291 exists.

Sources

Also known as DEBIAN-CVE-2025-54291, GHSA-xch9-h8qw-85c7, GO-2025-4005.

Is CVE-2025-54291 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free