# CVE-2025-54291: Project existence disclosure in LXD images API

> Unauthenticated attackers can determine project existence in LXD via differing HTTP status codes in the images API.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2025
- **Updated:** 2 Oct 2025
- **Also known as:** DEBIAN-CVE-2025-54291, GHSA-xch9-h8qw-85c7, GO-2025-4005

## What is CVE-2025-54291?

CVE-2025-54291 is a medium-severity vulnerability in Canonical LXD, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Information disclosure in images API in Canonical LXD before 6.5 and 5.21.4 on all platforms allows unauthenticated remote attackers to determine project existence via differing HTTP status code responses.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2025-54291?

7 open source packages ship an affected version, including github.com/canonical/lxd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/canonical/lxd` | Go | From 0.0.0-20200331193331-03aab09f5b5c | 0.0.0-20250827065555-0494f5d47e41 |
| `github.com/canonical/lxd` | Go | From 0.0.0-20200331193331-03aab09f5b5c | 0.0.0-20250827065555-0494f5d47e41 |
| `github.com/canonical/lxd` | Go | From 0.0.0-20200331193331-03aab09f5b5c | 0.0.0-20250827065555-0494f5d47e41 |
| `github.com/canonical/lxd` | Go | From 4.0 | 5.21.4 |
| `github.com/canonical/lxd` | Go | From 4.0 | 5.21.4 |
| `github.com/canonical/lxd` | Go | From 6.0 | 6.5 |
| `github.com/canonical/lxd` | Go | From 6.0 | 6.5 |

Products: Canonical Lxd.

## How do I fix CVE-2025-54291?

Upgrade github.com/canonical/lxd to a fixed version for your release line: 0.0.0-20250827065555-0494f5d47e41, 5.21.4 or 6.5.

## Is CVE-2025-54291 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54291 exists.

## Other vulnerabilities in Canonical LXD

- [CVE-2026-66897](https://insights.sbomify.com/CVE-2026-66897/): Instance template path traversal allows arbitrary host file write as root (critical 9.9)
- [CVE-2026-62420](https://insights.sbomify.com/CVE-2026-62420/): Cross-project cluster migration bypasses project restrictions via cluster notification flag (critical 9.9)
- [CVE-2026-63293](https://insights.sbomify.com/CVE-2026-63293/): Arbitrary File Read/Write: metadata.yaml symlink in image allows host filesystem access as root (critical 9.9)
- [CVE-2026-63294](https://insights.sbomify.com/CVE-2026-63294/): Root RCE via image backup.yaml symlink (critical 9.9)
- [CVE-2026-63296](https://insights.sbomify.com/CVE-2026-63296/): Project restriction bypass via instance migration config override (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54291 and fix it if it is affected.

What it is: CVE-2025-54291 is a medium-severity vulnerability in Canonical LXD, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54291 exists.

Affected packages and fixed versions:
- github.com/canonical/lxd (Go): affected from 0.0.0-20200331193331-03aab09f5b5c; fixed in 0.0.0-20250827065555-0494f5d47e41
- github.com/canonical/lxd (Go): affected from 0.0.0-20200331193331-03aab09f5b5c; fixed in 0.0.0-20250827065555-0494f5d47e41
- github.com/canonical/lxd (Go): affected from 0.0.0-20200331193331-03aab09f5b5c; fixed in 0.0.0-20250827065555-0494f5d47e41
- github.com/canonical/lxd (Go): affected from 4.0; fixed in 5.21.4
- github.com/canonical/lxd (Go): affected from 4.0; fixed in 5.21.4
- github.com/canonical/lxd (Go): affected from 6.0; fixed in 6.5
- github.com/canonical/lxd (Go): affected from 6.0; fixed in 6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54291/ (Markdown: https://insights.sbomify.com/CVE-2025-54291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54291
- OSV: https://osv.dev/vulnerability/CVE-2025-54291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54291/
Summaries are generated and may contain mistakes; the official description above is the record.
