{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-54314 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-54314 is a low-severity command injection vulnerability in rubyonrails Thor, published on 20 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54314 and fix it if it is affected.\n\nWhat it is: CVE-2025-54314 is a low-severity command injection vulnerability in rubyonrails Thor, published on 20 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54314 in the wild and no public exploit code.\n\nAffected product: rubyonrails Thor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54314/ (Markdown: https://insights.sbomify.com/CVE-2025-54314/index.md)","id":"CVE-2025-54314","markdown":"https://insights.sbomify.com/CVE-2025-54314/index.md","name":"CVE-2025-54314","record":{"aliases":["AZL-65613","AZL-65631","UBUNTU-CVE-2025-54314","openSUSE-SU-2025:15382-1","openSUSE-SU-2026:10366-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby CLI library","requires_auth":"low_privilege","summary":"An unsafe shell command construction in the Thor library could allow code execution, though the vendor disputes exploitability.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":2.8,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because \"the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments.\"","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in Thor","id":"CVE-2025-54314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"Business logic in Matrix specification","id":"CVE-2025-54315"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.0-1.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-thor","purl":"pkg:rpm/opensuse/rubygem-thor\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15382-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.0-1.3"],"introduced":["0"],"last_affected":[],"package":"rubygem-thor","purl":"pkg:rpm/opensuse/rubygem-thor\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10366-1"}],"prev":{"headline":"Prettier eslint-config-prettier Embedded Malicious Code","id":"CVE-2025-54313"},"products":["Thor"],"published":"2025-07-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-10","vendors":["rubyonrails"]},"summary":"An unsafe shell command construction in the Thor library could allow code execution, though the vendor disputes exploitability.","url":"https://insights.sbomify.com/CVE-2025-54314/"}