# CVE-2025-54365: fastapi-guard patch contains bypassable RegEx

> Attackers can bypass IP and penetration detection filters in fastapi-guard by using long strings, allowing unauthorized access or malicious requests to proceed.

- **Severity:** High 7.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2025
- **Updated:** 24 Jul 2025
- **Also known as:** GHSA-rrf6-pxg8-684g, PYSEC-2026-1360

## What is CVE-2025-54365?

CVE-2025-54365 is a high-severity vulnerability in rennf93 fastapi-guard, published on 23 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fastapi-guard is a security library for FastAPI that provides middleware to control IPs, log requests, detect penetration attempts and more. In version 3.0.1, the regular expression patched to mitigate the ReDoS vulnerability by limiting the length of string fails to catch inputs that exceed this limit. This type of patch fails to detect cases in which the string representing the attributes of a <script> tag exceeds 100 characters. As a result, most of the regex patterns present in version 3.0.1 can be bypassed. This is fixed in version 3.0.2.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-20 (Improper Input Validation), CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2025-54365?

3 open source packages ship an affected version, including fastapi-guard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastapi-guard` | PyPI | From 3.0.1 | 3.0.2 |
| `fastapi-guard` | PyPI | From 3.0.1 | 3.0.2 |
| `fastapi-guard` | PyPI | From 3.0.1 | 3.0.2 |

Products: Fastapi-Guard Fastapi Guard.

## How do I fix CVE-2025-54365?

Upgrade fastapi-guard to 3.0.2 or later.

## Is CVE-2025-54365 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54365 exists.

## Other vulnerabilities in rennf93 fastapi-guard

- [CVE-2025-53539](https://insights.sbomify.com/CVE-2025-53539/): ReDoS in fastapi-guard's penetration attempts detector (medium 6.9)
- [CVE-2025-46814](https://insights.sbomify.com/CVE-2025-46814/): FastAPI Guard Remote Header Injection via X-Forwarded-For Manipulation (low 3.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54365 and fix it if it is affected.

What it is: CVE-2025-54365 is a high-severity vulnerability in rennf93 fastapi-guard, published on 23 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54365 exists.

Affected packages and fixed versions:
- fastapi-guard (PyPI): affected from 3.0.1; fixed in 3.0.2
- fastapi-guard (PyPI): affected from 3.0.1; fixed in 3.0.2
- fastapi-guard (PyPI): affected from 3.0.1; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54365/ (Markdown: https://insights.sbomify.com/CVE-2025-54365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54365
- OSV: https://osv.dev/vulnerability/CVE-2025-54365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54365/
Summaries are generated and may contain mistakes; the official description above is the record.
