CVE-2025-54368 uv is vulnerable to ZIP payload obfuscation through parsing differentials

Medium 6.8 Published Updated

Attackers can craft malicious ZIP archives that execute different code depending on the installer, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-54368?

CVE-2025-54368 is a medium-severity vulnerability in astral-sh uv, published on 8 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

uv is a Python package and project manager written in Rust. In versions 0.8.5 and earlier, remote ZIP archives were handled in a streamwise fashion, and file entries were not reconciled against the archive's central directory. An attacker could contrive a ZIP archive that would extract with legitimate contents on some package installers, and malicious contents on others due to multiple local file entries. An attacker could also contrive a "stacked" ZIP input with multiple internal ZIPs, which would be handled differently by different package installers. The attacker could choose which installer to target in both scenarios. This issue is fixed in version 0.8.6. To work around this issue, users may choose to set UV_INSECURE_NO_ZIP_VALIDATION=1 to revert to the previous behavior.

Weakness: CWE-436, CWE-20

Which versions are affected by CVE-2025-54368?

3 open source packages ship an affected version, including uv.

PackageAffectedFixed in
uv PyPIAll versions0.8.6
uv PyPIAll versions0.8.6
uv PyPIAll versions0.8.6
Linux distribution packages (1)
python-uv openSUSE:TumbleweedAll versions0.8.8-1.1

How do I fix CVE-2025-54368?

Upgrade uv to 0.8.6 or later.

Is CVE-2025-54368 being exploited?

There is no known exploitation of CVE-2025-54368 in the wild and no public exploit code.

Sources

Also known as ECHO-ab98-58e8-47aa, GHSA-8qf3-x8v5-2pj8, PYSEC-2026-2001, openSUSE-SU-2025:15429-1.

Is CVE-2025-54368 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free