{"answers":{"affected":"3 open source packages ship an affected version, including uv.","exploited":"There is no known exploitation of CVE-2025-54368 in the wild and no public exploit code.","fix":"Upgrade uv to 0.8.6 or later.","what":"CVE-2025-54368 is a medium-severity vulnerability in astral-sh uv, published on 8 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-54368 and fix it if it is affected.\n\nWhat it is: CVE-2025-54368 is a medium-severity vulnerability in astral-sh uv, published on 8 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-54368 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uv (PyPI): affected all versions; fixed in 0.8.6\n- uv (PyPI): affected all versions; fixed in 0.8.6\n- uv (PyPI): affected all versions; fixed in 0.8.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54368/ (Markdown: https://insights.sbomify.com/CVE-2025-54368/index.md)","id":"CVE-2025-54368","markdown":"https://insights.sbomify.com/CVE-2025-54368/index.md","name":"CVE-2025-54368","record":{"aliases":["ECHO-ab98-58e8-47aa","GHSA-8qf3-x8v5-2pj8","PYSEC-2026-2001","openSUSE-SU-2025:15429-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python package manager","requires_auth":"none","summary":"Attackers can craft malicious ZIP archives that execute different code depending on the installer, potentially leading to code execution.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"uv is a Python package and project manager written in Rust. In versions 0.8.5 and earlier, remote ZIP archives were handled in a streamwise fashion, and file entries were not reconciled against the archive's central directory. An attacker could contrive a ZIP archive that would extract with legitimate contents on some package installers, and malicious contents on others due to multiple local file entries. An attacker could  also contrive a \"stacked\" ZIP input with multiple internal ZIPs, which would be handled differently by different package installers. The attacker could choose which installer to target in both scenarios. This issue is fixed in version 0.8.6. To work around this issue, users may choose to set UV_INSECURE_NO_ZIP_VALIDATION=1 to revert to the previous behavior.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"uv is vulnerable to ZIP payload obfuscation through parsing differentials","id":"CVE-2025-54368","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"Node-SAML SAML Authentication Bypass","id":"CVE-2025-54369"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":null,"source":"GHSA-8qf3-x8v5-2pj8"},{"ecosystem":"PyPI","fixed":["0.8.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"GHSA-8qf3-x8v5-2pj8"},{"ecosystem":"PyPI","fixed":["0.8.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"PYSEC-2026-2001"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.8.8-1.1"],"introduced":["0"],"last_affected":[],"package":"python-uv","purl":"pkg:rpm/opensuse/python-uv\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15429-1"}],"prev":{"headline":"FreeScout's deserialization of untrusted data leads to Remote Code Execution","id":"CVE-2025-54366"},"products":["uv"],"published":"2025-08-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-08","vendors":["astral-sh"]},"summary":"Attackers can craft malicious ZIP archives that execute different code depending on the installer, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2025-54368/"}