CVE-2025-54369 Node-SAML SAML Authentication Bypass
Attackers can bypass SAML authentication by modifying unsigned assertion details, potentially taking over accounts in applications using Node-SAML.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54369?
CVE-2025-54369 is a critical authentication bypass vulnerability in node-saml, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Node-SAML is a SAML library not dependent on any frameworks that runs in Node. In versions 5.0.1 and below, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. This issue is fixed in version 5.1.0.
Which versions are affected by CVE-2025-54369?
4 open source packages ship an affected version, including @node-saml/node-saml and node-saml.
| Package | Affected | Fixed in |
|---|---|---|
@node-saml/node-saml npm | All versions | 5.1.0 |
@node-saml/node-saml npm | All versions | 5.1.0 |
node-saml npm | All versions to 3.1.2 | None |
node-saml npm | All versions to 3.1.2 | None |
How do I fix CVE-2025-54369?
Upgrade @node-saml/node-saml to 5.1.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-54369 being exploited?
There is no known exploitation of CVE-2025-54369 in the wild and no public exploit code.
Sources
Also known as GHSA-m837-g268-mmv7.