{"answers":{"affected":"4 open source packages ship an affected version, including @node-saml/node-saml and node-saml.","exploited":"There is no known exploitation of CVE-2025-54369 in the wild and no public exploit code.","fix":"Upgrade @node-saml/node-saml to 5.1.0 or later.","what":"CVE-2025-54369 is a critical authentication bypass vulnerability in node-saml, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54369 and fix it if it is affected.\n\nWhat it is: CVE-2025-54369 is a critical authentication bypass vulnerability in node-saml, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54369 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @node-saml/node-saml (npm): affected all versions; fixed in 5.1.0\n- @node-saml/node-saml (npm): affected all versions; fixed in 5.1.0\n- node-saml (npm): affected all versions up to 3.1.2; no fix listed\n- node-saml (npm): affected all versions up to 3.1.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54369/ (Markdown: https://insights.sbomify.com/CVE-2025-54369/index.md)","id":"CVE-2025-54369","markdown":"https://insights.sbomify.com/CVE-2025-54369/index.md","name":"CVE-2025-54369","record":{"aliases":["GHSA-m837-g268-mmv7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SAML library","requires_auth":"none","summary":"Attackers can bypass SAML authentication by modifying unsigned assertion details, potentially taking over accounts in applications using Node-SAML.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-87","name":"Improper Neutralization of Alternate XSS Syntax"},{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Node-SAML is a SAML library not dependent on any frameworks that runs in Node. In versions 5.0.1 and below, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. This issue is fixed in version 5.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Node-SAML SAML Authentication Bypass","id":"CVE-2025-54369","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser","id":"CVE-2025-54370"},"packages":[{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"@node-saml/node-saml","purl":null,"source":"GHSA-m837-g268-mmv7"},{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"@node-saml/node-saml","purl":"pkg:npm/%40node-saml/node-saml","source":"GHSA-m837-g268-mmv7"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.1.2"],"package":"node-saml","purl":null,"source":"GHSA-m837-g268-mmv7"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.1.2"],"package":"node-saml","purl":"pkg:npm/node-saml","source":"GHSA-m837-g268-mmv7"}],"prev":{"headline":"uv is vulnerable to ZIP payload obfuscation through parsing differentials","id":"CVE-2025-54368"},"products":["node-saml"],"published":"2025-12-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-07","vendors":["node-saml"]},"summary":"Attackers can bypass SAML authentication by modifying unsigned assertion details, potentially taking over accounts in applications using Node-SAML.","url":"https://insights.sbomify.com/CVE-2025-54369/"}