# CVE-2025-54369: Node-SAML SAML Authentication Bypass

> Attackers can bypass SAML authentication by modifying unsigned assertion details, potentially taking over accounts in applications using Node-SAML.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 7 May 2026
- **Also known as:** GHSA-m837-g268-mmv7

## What is CVE-2025-54369?

CVE-2025-54369 is a critical authentication bypass vulnerability in node-saml, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node-SAML is a SAML library not dependent on any frameworks that runs in Node. In versions 5.0.1 and below, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. This issue is fixed in version 5.1.0.

Weakness: CWE-87 (Improper Neutralization of Alternate XSS Syntax), CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-54369?

4 open source packages ship an affected version, including @node-saml/node-saml and node-saml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@node-saml/node-saml` | npm | All versions | 5.1.0 |
| `@node-saml/node-saml` | npm | All versions | 5.1.0 |
| `node-saml` | npm | All versions to 3.1.2 | None |
| `node-saml` | npm | All versions to 3.1.2 | None |

## How do I fix CVE-2025-54369?

Upgrade @node-saml/node-saml to 5.1.0 or later.

## Is CVE-2025-54369 being exploited?

There is no known exploitation of CVE-2025-54369 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54369 and fix it if it is affected.

What it is: CVE-2025-54369 is a critical authentication bypass vulnerability in node-saml, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54369 in the wild and no public exploit code.

Affected packages and fixed versions:
- @node-saml/node-saml (npm): affected all versions; fixed in 5.1.0
- @node-saml/node-saml (npm): affected all versions; fixed in 5.1.0
- node-saml (npm): affected all versions up to 3.1.2; no fix listed
- node-saml (npm): affected all versions up to 3.1.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54369/ (Markdown: https://insights.sbomify.com/CVE-2025-54369/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54369
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54369
- OSV: https://osv.dev/vulnerability/CVE-2025-54369

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54369/
Summaries are generated and may contain mistakes; the official description above is the record.
