{"answers":{"affected":"10 open source packages ship an affected version, including phpoffice/phpspreadsheet.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54370 exists.","fix":"Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.0, 2.1.12, 2.4.0 or 3.10.0.","what":"CVE-2025-54370 is a high-severity server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54370 and fix it if it is affected.\n\nWhat it is: CVE-2025-54370 is a high-severity server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54370 exists.\n\nAffected packages and fixed versions:\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.0\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.0\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.12\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.12\n- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.0\n- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.0\n- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.10.0\n- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.10.0\n- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.0.0\n- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54370/ (Markdown: https://insights.sbomify.com/CVE-2025-54370/index.md)","id":"CVE-2025-54370","markdown":"https://insights.sbomify.com/CVE-2025-54370/index.md","name":"CVE-2025-54370","record":{"aliases":["CLSA-2026-1768525047","GHSA-rx7m-68vc-ppxh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP spreadsheet library","requires_auth":"none","summary":"Attackers can trigger Server-Side Request Forgery in PhpSpreadsheet by crafting HTML documents, potentially accessing internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\\PhpSpreadsheet\\Worksheet\\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser","id":"CVE-2025-54370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":10,"n_references":6,"next":{"headline":"This CVE is a duplicate of another CVE.","id":"CVE-2025-54371"},"packages":[{"ecosystem":"Packagist","fixed":["1.30.0"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["1.30.0"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["2.1.12"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["2.1.12"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["2.4.0"],"introduced":["2.2.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["2.4.0"],"introduced":["2.2.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["3.10.0"],"introduced":["3.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["3.10.0"],"introduced":["3.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["5.0.0"],"introduced":["4.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-rx7m-68vc-ppxh"},{"ecosystem":"Packagist","fixed":["5.0.0"],"introduced":["4.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-rx7m-68vc-ppxh"}],"prev":{"headline":"Node-SAML SAML Authentication Bypass","id":"CVE-2025-54369"},"products":["PhpSpreadsheet"],"published":"2025-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-25","vendors":["PHPOffice"]},"summary":"Attackers can trigger Server-Side Request Forgery in PhpSpreadsheet by crafting HTML documents, potentially accessing internal resources.","url":"https://insights.sbomify.com/CVE-2025-54370/"}