# CVE-2025-54370: PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser

> Attackers can trigger Server-Side Request Forgery in PhpSpreadsheet by crafting HTML documents, potentially accessing internal resources.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2025
- **Updated:** 25 Aug 2025
- **Also known as:** CLSA-2026-1768525047, GHSA-rx7m-68vc-ppxh

## What is CVE-2025-54370?

CVE-2025-54370 is a high-severity server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-54370?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.0 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.12 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.12 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.0.0 | 3.10.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.0.0 | 3.10.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.0.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.0.0 |

## How do I fix CVE-2025-54370?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.0, 2.1.12, 2.4.0 or 3.10.0.

## Is CVE-2025-54370 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54370 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54370 and fix it if it is affected.

What it is: CVE-2025-54370 is a high-severity server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54370 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.0
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.0
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.12
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.12
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.0
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.0
- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.10.0
- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.10.0
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.0.0
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54370/ (Markdown: https://insights.sbomify.com/CVE-2025-54370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54370
- OSV: https://osv.dev/vulnerability/CVE-2025-54370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54370/
Summaries are generated and may contain mistakes; the official description above is the record.
