CVE-2025-54377 Roo Code Lacks Line Break Validation in its Command Execution Tool

High 7.8 Published Updated

Attackers can bypass command allow-lists by injecting line breaks, enabling arbitrary command execution in the Roo Code AI agent.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-54377?

CVE-2025-54377 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions 3.23.18 and below, RooCode does not validate line breaks (\n) in its command input, allowing potential bypass of the allow-list mechanism. The project appears to lack parsing or validation logic to prevent multi-line command injection. When commands are evaluated for execution, only the first line or token may be considered, enabling attackers to smuggle additional commands in subsequent lines. This is fixed in version 3.23.19.

Weakness: CWE-77

Which versions are affected by CVE-2025-54377?

It affects 1 product.

Products include Roocode Roo Code.

How do I fix CVE-2025-54377?

No fix has been published for CVE-2025-54377 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-54377 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54377 exists.

Sources

Also known as GHSA-p278-52x9-cffx.

Is CVE-2025-54377 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free