{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54377 exists.","fix":"No fix has been published for CVE-2025-54377 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-54377 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54377 and fix it if it is affected.\n\nWhat it is: CVE-2025-54377 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54377 exists.\n\nAffected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54377/ (Markdown: https://insights.sbomify.com/CVE-2025-54377/index.md)","id":"CVE-2025-54377","markdown":"https://insights.sbomify.com/CVE-2025-54377/index.md","name":"CVE-2025-54377","record":{"aliases":["GHSA-p278-52x9-cffx"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AI coding agent","requires_auth":"low_privilege","summary":"Attackers can bypass command allow-lists by injecting line breaks, enabling arbitrary command execution in the Roo Code AI agent.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"roo_code","vendor":"roocode"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions 3.23.18 and below, RooCode does not validate line breaks (\\n) in its command input, allowing potential bypass of the allow-list mechanism. The project appears to lack parsing or validation logic to prevent multi-line command injection. When commands are evaluated for execution, only the first line or token may be considered, enabling attackers to smuggle additional commands in subsequent lines. This is fixed in version 3.23.19.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Roo Code Lacks Line Break Validation in its Command Execution Tool","id":"CVE-2025-54377","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"HAX CMS Backend Lacks Comprehensive Authorization Checks","id":"CVE-2025-54378"},"packages":[],"prev":{"headline":"Hoverfly's WebSocket endpoint `/api/v2/ws/logs` reachable without authentication even when --auth is enabled.","id":"CVE-2025-54376"},"products":["Roo-Code"],"published":"2025-07-23","related":[{"cvss_score":9.9,"headline":"Roo Code is vulnerable to command injection via GitHub actions workflow","id":"CVE-2025-58371","kev_date_added":null,"published":"2025-09-05"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2026-30307","kev_date_added":null,"published":"2026-03-30"},{"cvss_score":8.1,"headline":"Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug","id":"CVE-2025-65946","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":8.1,"headline":"Roo Code: Potential Remote Code Execution via Bash Parameter Expansion and Indirect Reference","id":"CVE-2025-58370","kev_date_added":null,"published":"2025-09-05"},{"cvss_score":8.1,"headline":"Roo Code: Potential Remote Code Execution via .code-workspace","id":"CVE-2025-58372","kev_date_added":null,"published":"2025-09-05"},{"cvss_score":8.1,"headline":"Roo Code allows Potential Remote Code Execution via .vscode/settings.json","id":"CVE-2025-53536","kev_date_added":null,"published":"2025-07-07"},{"cvss_score":8.1,"headline":"Roo Code Vulnerable to Potential Remote Code Execution via Model Context Protocol","id":"CVE-2025-53098","kev_date_added":null,"published":"2025-06-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-23","vendors":["RooCodeInc"]},"summary":"Attackers can bypass command allow-lists by injecting line breaks, enabling arbitrary command execution in the Roo Code AI agent.","url":"https://insights.sbomify.com/CVE-2025-54377/"}