# CVE-2025-54377: Roo Code Lacks Line Break Validation in its Command Execution Tool

> Attackers can bypass command allow-lists by injecting line breaks, enabling arbitrary command execution in the Roo Code AI agent.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-p278-52x9-cffx

## What is CVE-2025-54377?

CVE-2025-54377 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions 3.23.18 and below, RooCode does not validate line breaks (\n) in its command input, allowing potential bypass of the allow-list mechanism. The project appears to lack parsing or validation logic to prevent multi-line command injection. When commands are evaluated for execution, only the first line or token may be considered, enabling attackers to smuggle additional commands in subsequent lines. This is fixed in version 3.23.19.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-54377?

It affects 1 product.


Products: Roocode Roo Code.

## How do I fix CVE-2025-54377?

No fix has been published for CVE-2025-54377 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54377 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54377 exists.

## Other vulnerabilities in RooCodeInc Roo-Code

- [CVE-2025-58371](https://insights.sbomify.com/CVE-2025-58371/): Roo Code is vulnerable to command injection via GitHub actions workflow (critical 9.9)
- [CVE-2026-30307](https://insights.sbomify.com/CVE-2026-30307/): Command injection in n/a (critical 9.8)
- [CVE-2025-65946](https://insights.sbomify.com/CVE-2025-65946/): Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug (high 8.1)
- [CVE-2025-58370](https://insights.sbomify.com/CVE-2025-58370/): Roo Code: Potential Remote Code Execution via Bash Parameter Expansion and Indirect Reference (high 8.1)
- [CVE-2025-58372](https://insights.sbomify.com/CVE-2025-58372/): Roo Code: Potential Remote Code Execution via .code-workspace (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54377 and fix it if it is affected.

What it is: CVE-2025-54377 is a high-severity command injection vulnerability in RooCodeInc Roo-Code, published on 23 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54377 exists.

Affected product: RooCodeInc Roo-Code. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54377/ (Markdown: https://insights.sbomify.com/CVE-2025-54377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54377
- OSV: https://osv.dev/vulnerability/CVE-2025-54377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54377/
Summaries are generated and may contain mistakes; the official description above is the record.
