{"answers":{"affected":"4 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs and elmsln/haxcms. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54378 exists.","fix":"Upgrade @haxtheweb/haxcms-nodejs to 11.0.14 or later.","what":"CVE-2025-54378 is a high-severity missing authorization vulnerability in haxtheweb issues, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54378 and fix it if it is affected.\n\nWhat it is: CVE-2025-54378 is a high-severity missing authorization vulnerability in haxtheweb issues, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54378 exists.\n\nAffected packages and fixed versions:\n- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.14\n- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.14\n- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.14\n- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54378/ (Markdown: https://insights.sbomify.com/CVE-2025-54378/index.md)","id":"CVE-2025-54378","markdown":"https://insights.sbomify.com/CVE-2025-54378/index.md","name":"CVE-2025-54378","record":{"aliases":["GHSA-9jr9-8ff3-m894"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"HAX CMS","requires_auth":"low_privilege","summary":"Attackers can access or modify resources without proper permission checks because HAX CMS API endpoints fail to verify user authorization.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"haxcms-nodejs","vendor":"psu"},{"product":"haxcms-php","vendor":"psu"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"HAX CMS allows you to manage your microsite universe with PHP or NodeJs backends. In versions 11.0.13 and below of haxcms-nodejs and versions 11.0.8 and below of haxcms-php, API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation. The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation. This is fixed in versions 11.0.14 of haxcms-nodejs and 11.0.9 of haxcms-php.","ecosystems":["Packagist","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"HAX CMS Backend Lacks Comprehensive Authorization Checks","id":"CVE-2025-54378","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"eKuiper API endpoints handling SQL queries with user-controlled table names.","id":"CVE-2025-54379"},"packages":[{"ecosystem":"Packagist","fixed":["11.0.14"],"introduced":["0"],"last_affected":[],"package":"elmsln/haxcms","purl":null,"source":"GHSA-9jr9-8ff3-m894"},{"ecosystem":"Packagist","fixed":["11.0.14"],"introduced":["0"],"last_affected":[],"package":"elmsln/haxcms","purl":"pkg:composer/elmsln/haxcms","source":"GHSA-9jr9-8ff3-m894"},{"ecosystem":"npm","fixed":["11.0.14"],"introduced":["0"],"last_affected":[],"package":"@haxtheweb/haxcms-nodejs","purl":null,"source":"GHSA-9jr9-8ff3-m894"},{"ecosystem":"npm","fixed":["11.0.14"],"introduced":["0"],"last_affected":[],"package":"@haxtheweb/haxcms-nodejs","purl":"pkg:npm/%40haxtheweb/haxcms-nodejs","source":"GHSA-9jr9-8ff3-m894"}],"prev":{"headline":"Roo Code Lacks Line Break Validation in its Command Execution Tool","id":"CVE-2025-54377"},"products":["issues"],"published":"2025-07-26","related":[{"cvss_score":9.3,"headline":"HAXcms's Insecure Default Configuration Leads to Unauthenticated Access","id":"CVE-2025-54127","kev_date_added":null,"published":"2025-07-21"},{"cvss_score":8.6,"headline":"HaxCMS-PHP Command Injection Vulnerability","id":"CVE-2025-49141","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.5,"headline":"Hax CMS Stored Cross-Site Scripting vulnerability","id":"CVE-2025-49137","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.1,"headline":"HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover","id":"CVE-2026-22704","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":7.3,"headline":"NodeJS version of the HAX CMS application is distributed with Default Secrets","id":"CVE-2025-54137","kev_date_added":null,"published":"2025-07-22"},{"cvss_score":7.2,"headline":"HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting","id":"CVE-2025-54128","kev_date_added":null,"published":"2025-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-28","vendors":["haxtheweb"]},"summary":"Attackers can access or modify resources without proper permission checks because HAX CMS API endpoints fail to verify user authorization.","url":"https://insights.sbomify.com/CVE-2025-54378/"}