# CVE-2025-54378: HAX CMS Backend Lacks Comprehensive Authorization Checks

> Attackers can access or modify resources without proper permission checks because HAX CMS API endpoints fail to verify user authorization.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-9jr9-8ff3-m894

## What is CVE-2025-54378?

CVE-2025-54378 is a high-severity missing authorization vulnerability in haxtheweb issues, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HAX CMS allows you to manage your microsite universe with PHP or NodeJs backends. In versions 11.0.13 and below of haxcms-nodejs and versions 11.0.8 and below of haxcms-php, API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation. The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation. This is fixed in versions 11.0.14 of haxcms-nodejs and 11.0.9 of haxcms-php.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-54378?

4 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs and elmsln/haxcms. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.14 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.14 |
| `elmsln/haxcms` | Packagist | All versions | 11.0.14 |
| `elmsln/haxcms` | Packagist | All versions | 11.0.14 |

Products: Psu Haxcms-Nodejs, Psu Haxcms-Php.

## How do I fix CVE-2025-54378?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.14 or later.

## Is CVE-2025-54378 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54378 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)
- [CVE-2025-54137](https://insights.sbomify.com/CVE-2025-54137/): NodeJS version of the HAX CMS application is distributed with Default Secrets (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54378 and fix it if it is affected.

What it is: CVE-2025-54378 is a high-severity missing authorization vulnerability in haxtheweb issues, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54378 exists.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.14
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.14
- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.14
- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54378/ (Markdown: https://insights.sbomify.com/CVE-2025-54378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54378
- OSV: https://osv.dev/vulnerability/CVE-2025-54378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54378/
Summaries are generated and may contain mistakes; the official description above is the record.
