# CVE-2025-54379: eKuiper API endpoints handling SQL queries with user-controlled table names.

> Unauthenticated attackers can execute arbitrary SQL commands via manipulated table names in API requests, leading to database compromise.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2025
- **Updated:** 25 Jul 2025
- **Also known as:** GHSA-526j-mv3p-f4vv, GO-2025-3827, PYSEC-2025-241

## What is CVE-2025-54379?

CVE-2025-54379 is a high-severity SQL injection vulnerability in lf-edge ekuiper, published on 24 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LF Edge eKuiper is a lightweight IoT data analytics and stream processing engine running on resource-constraint edge devices. In versions before 2.2.1, there is a critical SQL Injection vulnerability in the getLast API functionality of the eKuiper project. This flaw allows unauthenticated remote attackers to execute arbitrary SQL statements on the underlying SQLite database by manipulating the table name input in an API request. Exploitation can lead to data theft, corruption, or deletion, and full database compromise. This is fixed in version 2.2.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-54379?

7 open source packages ship an affected version, including github.com/lf-edge/ekuiper, github.com/lf-edge/ekuiper/v2 and ekuiper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lf-edge/ekuiper` | Go | All versions | None |
| `github.com/lf-edge/ekuiper` | Go | All versions to 1.14.7 | None |
| `github.com/lf-edge/ekuiper` | Go | All versions to 1.14.7 | None |
| `github.com/lf-edge/ekuiper/v2` | Go | All versions | 2.2.1 |
| `github.com/lf-edge/ekuiper/v2` | Go | All versions | 2.2.1 |
| `github.com/lf-edge/ekuiper/v2` | Go | All versions | 2.2.1 |
| `ekuiper` | PyPI | All versions to 2.1.5 | None |

Products: Lfedge Ekuiper.

## How do I fix CVE-2025-54379?

Upgrade to a fixed version.

## Is CVE-2025-54379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54379 exists.

## Other vulnerabilities in lf-edge ekuiper

- [CVE-2024-43406](https://insights.sbomify.com/CVE-2024-43406/): LF Edge eKuiper has a SQL Injection in sqlKvStore (high 8.8)
- [CVE-2024-52290](https://insights.sbomify.com/CVE-2024-52290/): Stored XSS in Configuration Key Functionality (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54379 and fix it if it is affected.

What it is: CVE-2025-54379 is a high-severity SQL injection vulnerability in lf-edge ekuiper, published on 24 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54379 exists.

Affected packages and fixed versions:
- github.com/lf-edge/ekuiper (Go): affected all versions; no fix listed
- github.com/lf-edge/ekuiper (Go): affected all versions up to 1.14.7; no fix listed
- github.com/lf-edge/ekuiper (Go): affected all versions up to 1.14.7; no fix listed
- github.com/lf-edge/ekuiper/v2 (Go): affected all versions; fixed in 2.2.1
- github.com/lf-edge/ekuiper/v2 (Go): affected all versions; fixed in 2.2.1
- github.com/lf-edge/ekuiper/v2 (Go): affected all versions; fixed in 2.2.1
- ekuiper (PyPI): affected all versions up to 2.1.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54379/ (Markdown: https://insights.sbomify.com/CVE-2025-54379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54379
- OSV: https://osv.dev/vulnerability/CVE-2025-54379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54379/
Summaries are generated and may contain mistakes; the official description above is the record.
