# CVE-2025-54380: Opencast still publishes global system account credentials

> Attackers with ingest permissions can force Opencast to leak hashed global system account credentials to arbitrary URLs.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-j63h-hmgw-x4j7

## What is CVE-2025-54380?

CVE-2025-54380 is a medium-severity vulnerability in opencast, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Opencast is a free, open-source platform to support the management of educational audio and video content. Prior to version 17.6, Opencast would incorrectly send the hashed global system account credentials (ie: org.opencastproject.security.digest.user and org.opencastproject.security.digest.pass) when attempting to fetch mediapackage elements included in a mediapackage XML file. A previous CVE prevented many cases where the credentials were inappropriately sent, but not all. Anyone with ingest permissions could cause Opencast to send its hashed global system account credentials to a url of their choosing. This issue is fixed in Opencast 17.6.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-54380?

8 open source packages ship an affected version, including org.opencastproject:opencast-common, org.opencastproject:opencast-ingest-service-impl and org.opencastproject:opencast-kernel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-common` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-common` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-ingest-service-impl` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-ingest-service-impl` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-kernel` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-kernel` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-publication-service-oaipmh-remote` | Maven | All versions | 17.6 |
| `org.opencastproject:opencast-publication-service-oaipmh-remote` | Maven | All versions | 17.6 |

Products: Apereo Opencast.

## How do I fix CVE-2025-54380?

Upgrade org.opencastproject:opencast-common to 17.6 or later.

## Is CVE-2025-54380 being exploited?

There is no known exploitation of CVE-2025-54380 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54380 and fix it if it is affected.

What it is: CVE-2025-54380 is a medium-severity vulnerability in opencast, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54380 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-common (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-common (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-ingest-service-impl (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-ingest-service-impl (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-kernel (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-kernel (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-publication-service-oaipmh-remote (Maven): affected all versions; fixed in 17.6
- org.opencastproject:opencast-publication-service-oaipmh-remote (Maven): affected all versions; fixed in 17.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54380/ (Markdown: https://insights.sbomify.com/CVE-2025-54380/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54380
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54380
- OSV: https://osv.dev/vulnerability/CVE-2025-54380

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54380/
Summaries are generated and may contain mistakes; the official description above is the record.
