# CVE-2025-54384: CKAN stored XSS vulnerability in Markdown description fields

> Attackers can inject malicious scripts via Markdown fields in CKAN, potentially stealing user sessions or executing code.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-2r4h-8jxv-w2j8, PYSEC-2026-1247

## What is CVE-2025-54384?

CVE-2025-54384 is a medium-severity cross-site scripting vulnerability in ckan, published on 29 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-54384?

5 open source packages ship an affected version, including ckan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckan` | PyPI | All versions | 2.10.9, 2.11.4 |
| `ckan` | PyPI | All versions | 2.10.9 |
| `ckan` | PyPI | All versions | 2.10.9 |
| `ckan` | PyPI | From 2.11.0 | 2.11.4 |
| `ckan` | PyPI | From 2.11.0 | 2.11.4 |

## How do I fix CVE-2025-54384?

Upgrade ckan to a fixed version for your release line: 2.10.9 or 2.11.4.

## Is CVE-2025-54384 being exploited?

There is no known exploitation of CVE-2025-54384 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54384 and fix it if it is affected.

What it is: CVE-2025-54384 is a medium-severity cross-site scripting vulnerability in ckan, published on 29 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-54384 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckan (PyPI): affected all versions; fixed in 2.10.9, 2.11.4
- ckan (PyPI): affected all versions; fixed in 2.10.9
- ckan (PyPI): affected all versions; fixed in 2.10.9
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.4
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54384/ (Markdown: https://insights.sbomify.com/CVE-2025-54384/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54384
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54384
- OSV: https://osv.dev/vulnerability/CVE-2025-54384

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54384/
Summaries are generated and may contain mistakes; the official description above is the record.
