# CVE-2025-54385: XWiki Platform's searchDocuments API allows for SQL injection

> Attackers can execute arbitrary SQL queries via the searchDocuments API, potentially reading or modifying database contents.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-p9qm-p942-q3w5

## What is CVE-2025-54385?

CVE-2025-54385 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 26 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions between 17.0.0-rc1 to 17.2.2 and versions 16.10.5 and below, it's possible to execute any SQL query in Oracle by using the function like DBMS_XMLGEN or DBMS_XMLQUERY. The XWiki#searchDocuments APIs pass queries directly to Hibernate without sanitization. Even when these APIs enforce a specific SELECT clause, attackers can still inject malicious code through HQL's native function support in other parts of the query (such as the WHERE clause). This is fixed in versions 16.10.6 and 17.3.0-rc-1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-54385?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 16.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 16.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc1 | 17.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc1 | 17.3.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-54385?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 16.10.6 or 17.3.0-rc-1.

## Is CVE-2025-54385 being exploited?

There is no known exploitation of CVE-2025-54385 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54385 and fix it if it is affected.

What it is: CVE-2025-54385 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 26 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54385 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 16.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 16.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc1; fixed in 17.3.0-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc1; fixed in 17.3.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54385/ (Markdown: https://insights.sbomify.com/CVE-2025-54385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54385
- OSV: https://osv.dev/vulnerability/CVE-2025-54385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54385/
Summaries are generated and may contain mistakes; the official description above is the record.
