# CVE-2025-54387: IPX is Vulnerable to Path Traversal via Prefix Matching Bypass

> Attackers can read files outside allowed directories in IPX due to a path prefix bypass vulnerability in directory checks.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-mm3p-j368-7jcr

## What is CVE-2025-54387?

CVE-2025-54387 is a medium-severity path traversal vulnerability in unjs ipx, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

IPX is an image optimizer powered by sharp and svgo. In versions 1.3.1 and below, 2.0.0-0 through 2.1.0, and 3.0.0 through 3.1.0, the approach used to check whether a path is within allowed directories is vulnerable to path prefix bypass when the allowed directories do not end with a path separator. This occurs because the check relies on a raw string prefix comparison. This is fixed in versions 1.3.2, 2.1.1 and 3.1.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-54387?

6 open source packages ship an affected version, including ipx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipx` | npm | All versions | 1.3.2 |
| `ipx` | npm | All versions | 1.3.2 |
| `ipx` | npm | From 2.0.0-0 | 2.1.1 |
| `ipx` | npm | From 2.0.0-0 | 2.1.1 |
| `ipx` | npm | From 3.0.0 | 3.1.1 |
| `ipx` | npm | From 3.0.0 | 3.1.1 |

Products: Unjs Ipx.

## How do I fix CVE-2025-54387?

Upgrade ipx to a fixed version for your release line: 1.3.2, 2.1.1 or 3.1.1.

## Is CVE-2025-54387 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54387 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54387 and fix it if it is affected.

What it is: CVE-2025-54387 is a medium-severity path traversal vulnerability in unjs ipx, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54387 exists.

Affected packages and fixed versions:
- ipx (npm): affected all versions; fixed in 1.3.2
- ipx (npm): affected all versions; fixed in 1.3.2
- ipx (npm): affected from 2.0.0-0; fixed in 2.1.1
- ipx (npm): affected from 2.0.0-0; fixed in 2.1.1
- ipx (npm): affected from 3.0.0; fixed in 3.1.1
- ipx (npm): affected from 3.0.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54387/ (Markdown: https://insights.sbomify.com/CVE-2025-54387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54387
- OSV: https://osv.dev/vulnerability/CVE-2025-54387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54387/
Summaries are generated and may contain mistakes; the official description above is the record.
