CVE-2025-54388 Moby's Firewalld reload makes published container ports accessible from remote hosts
Firewalld reloads remove Docker's localhost port restrictions, exposing container ports to remote attackers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-54388?
CVE-2025-54388 is a medium-severity vulnerability in moby, published on 30 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Moby is an open source container framework developed by Docker Inc. that is distributed as Docker Engine, Mirantis Container Runtime, and various other downstream projects/products. In versions 28.2.0 through 28.3.2, when the firewalld service is reloaded it removes all iptables rules including those created by Docker. While Docker should automatically recreate these rules, versions before 28.3.3 fail to recreate the specific rules that block external access to containers. This means that after a firewalld reload, containers with ports published to localhost (like 127.0.0.1:8080) become accessible from remote machines that have network routing to the Docker bridge, even though they should only be accessible from the host itself. The vulnerability only affects explicitly published ports - unpublished ports remain protected. This issue is fixed in version 28.3.3.
Weakness: CWE-909
Which versions are affected by CVE-2025-54388?
3 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/docker/docker Go | From 28.2.0 | 28.3.3 |
github.com/docker/docker Go | From 28.2.0 | 28.3.3 |
github.com/docker/docker Go | From 28.2.0+incompatible | 28.3.3+incompatible |
Linux distribution packages (30)
docker SUSE:Enterprise Storage 7.1 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Micro 5.1 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Micro 5.2 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Micro 5.3 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Micro 5.4 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Micro 5.5 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Module for Containers 15 SP6 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Module for Containers 15 SP7 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 28.3.3_ce-98.137.1 |
docker SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server 16.0 | All versions | 28.5.1_ce-160000.4.1 |
docker SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 28.3.3_ce-98.137.1 |
docker SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 28.3.3_ce-150000.230.1 |
docker SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 28.5.1_ce-160000.4.1 |
docker SUSE:Linux Micro 6.0 | All versions | 28.3.3_ce-6.1 |
docker SUSE:Linux Micro 6.1 | All versions | 28.4.0_ce-slfo.1.1_6.1 |
docker SUSE:Linux Micro 6.2 | All versions | 28.5.1_ce-160000.4.1 |
docker openSUSE:Leap 15.6 | All versions | 28.3.3_ce-150000.230.1 |
docker openSUSE:Leap 16.0 | All versions | 28.5.1_ce-160000.4.1 |
docker openSUSE:Tumbleweed | All versions | 28.3.3_ce-26.1 |
Products include Mobyproject Moby.
How do I fix CVE-2025-54388?
Upgrade github.com/docker/docker to a fixed version for your release line: 28.3.3 or 28.3.3+incompatible.
Is CVE-2025-54388 being exploited?
There is no known exploitation of CVE-2025-54388 in the wild and no public exploit code.
Other vulnerabilities in moby
- CVE-2024-36623 Moby Race Condition vulnerability
- CVE-2023-28840 moby/moby's dockerd daemon encrypted overlay network may be unauthenticated
- CVE-2018-12608 Docker Authentication Bypass
- CVE-2024-24557 Moby classic builder cache poisoning
- CVE-2023-28841 moby/moby's dockerd daemon encrypted overlay network traffic may be unencrypted
Sources
Also known as BELL-CVE-2025-54388, CLEANSTART-2025-VP24183, GHSA-x4rx-4gw3-53p4, GO-2025-3830, MINI-2296-9mvh-8mc4, MINI-2p25-r653-6cpj and 19 more.