CVE-2025-54410 Moby's Firewalld reload removes bridge network isolation
Firewalld reloads remove Docker bridge network isolation, allowing cross-network container access and bypassing segmentation in multi-tenant environments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-54410?
CVE-2025-54410 is a low-severity missing authorization vulnerability in moby, published on 30 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Moby is an open source container framework developed by Docker Inc. that is distributed as Docker Engine, Mirantis Container Runtime, and various other downstream projects/products. A firewalld vulnerability affects Moby releases before 28.0.0. When firewalld reloads, Docker fails to re-create iptables rules that isolate bridge networks, allowing any container to access all ports on any other container across different bridge networks on the same host. This breaks network segmentation between containers that should be isolated, creating significant risk in multi-tenant environments. Only containers in --internal networks remain protected. Workarounds include reloading firewalld and either restarting the docker daemon, re-creating bridge networks, or using rootless mode. Maintainers anticipate a fix for this issue in version 25.0.13.
Weakness: CWE-909
Which versions are affected by CVE-2025-54410?
5 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/docker/docker Go | All versions | 25.0.13 |
github.com/docker/docker Go | All versions | 25.0.13 |
github.com/docker/docker Go | All versions | 25.0.13+incompatible |
github.com/docker/docker Go | From 26.0.0-rc1 | 28.0.0 |
github.com/docker/docker Go | From 26.0.0-rc1 | 28.0.0 |
Products include Mobyproject Moby.
How do I fix CVE-2025-54410?
Upgrade github.com/docker/docker to a fixed version for your release line: 25.0.13, 25.0.13+incompatible or 28.0.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-54410 being exploited?
There is no known exploitation of CVE-2025-54410 in the wild and no public exploit code.
Other vulnerabilities in moby
- CVE-2024-36623 Moby Race Condition vulnerability
- CVE-2023-28840 moby/moby's dockerd daemon encrypted overlay network may be unauthenticated
- CVE-2018-12608 Docker Authentication Bypass
- CVE-2024-24557 Moby classic builder cache poisoning
- CVE-2023-28841 moby/moby's dockerd daemon encrypted overlay network traffic may be unencrypted
Sources
Also known as BELL-CVE-2025-54410, CLEANSTART-2026-IQ97259, CLEANSTART-2026-JE43065, CLEANSTART-2026-JX33746, CLEANSTART-2026-KB70084, DEBIAN-CVE-2025-54410 and 56 more.