# CVE-2025-54410: Moby's Firewalld reload removes bridge network isolation

> Firewalld reloads remove Docker bridge network isolation, allowing cross-network container access and bypassing segmentation in multi-tenant environments.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** BELL-CVE-2025-54410, CLEANSTART-2026-IQ97259, CLEANSTART-2026-JE43065, CLEANSTART-2026-JX33746, CLEANSTART-2026-KB70084, DEBIAN-CVE-2025-54410, ECHO-d59e-2c08-ecef, GHSA-4vq8-7jfc-9cvp, GO-2025-3829, MINI-27xf-2chf-5p8j, MINI-2jmq-44xh-f359, MINI-3jqq-7h72-675p, MINI-3w5v-mhm4-8g58, MINI-54rf-cr76-p79f, MINI-5c47-7w6r-mqq9, MINI-5f4v-w729-444c, MINI-5hj7-g3cg-rp2j, MINI-6gc7-w5f5-4fq8, MINI-6qfc-gpjx-9wj9, MINI-6x85-56vh-x227, MINI-84cv-vmxj-423g, MINI-8gxg-jpj8-v35h, MINI-8hxh-vw4p-3hcc, MINI-8r2m-gj79-gjcw, MINI-93jw-rgvf-jm43, MINI-96gg-3m3j-98qc, MINI-9fmf-xpvw-f35h, MINI-c2vv-4j84-8f6c, MINI-c53p-2qvf-rffw, MINI-cg5g-fqxg-8r3j, MINI-cxrj-xjh2-m469, MINI-f29v-qfgm-v4jj, MINI-fhqj-97cx-3p75, MINI-fjwr-65ph-v4mh, MINI-fmp5-2vmg-3hhw, MINI-frh2-prxv-49vw, MINI-g3gq-384p-fgmw, MINI-grx9-mj7h-g73q, MINI-h284-h59g-pfrj, MINI-h2hv-cwm7-xr9w, MINI-j76c-77x4-jq2v, MINI-jh8v-2459-pgr9, MINI-jj9r-mq53-56mw, MINI-jvwj-j6jf-22j8, MINI-m663-3j3c-p7hp, MINI-m673-5xcr-6ch5, MINI-mp6x-p6v8-962x, MINI-mx9g-v3vh-487p, MINI-p675-9c7g-62g6, MINI-pp65-wj8x-cg39, MINI-q3rh-69gx-6qqx, MINI-qj33-vjwx-f2j9, MINI-rf84-vh22-cxwq, MINI-vq67-4648-6284, MINI-wfmv-49h6-rhfx, MINI-x325-p46w-pc5j, MINI-x4vc-37pr-9qm5, MINI-x89p-7v9r-p32x, MINI-x9pm-hh7g-7646, MINI-xmr2-9j3f-xj8c, MINI-xxr6-p4r3-9cgp, UBUNTU-CVE-2025-54410

## What is CVE-2025-54410?

CVE-2025-54410 is a low-severity missing authorization vulnerability in moby, published on 30 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Moby is an open source container framework developed by Docker Inc. that is distributed as Docker Engine, Mirantis Container Runtime, and various other downstream projects/products. A firewalld vulnerability affects Moby releases before 28.0.0. When firewalld reloads, Docker fails to re-create iptables rules that isolate bridge networks, allowing any container to access all ports on any other container across different bridge networks on the same host. This breaks network segmentation between containers that should be isolated, creating significant risk in multi-tenant environments. Only containers in --internal networks remain protected.
Workarounds include reloading firewalld and either restarting the docker daemon, re-creating bridge networks, or using rootless mode. Maintainers anticipate a fix for this issue in version 25.0.13.

Weakness: CWE-909 (Missing Initialization of Resource)

## Which versions are affected by CVE-2025-54410?

5 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker` | Go | All versions | 25.0.13 |
| `github.com/docker/docker` | Go | All versions | 25.0.13 |
| `github.com/docker/docker` | Go | All versions | 25.0.13+incompatible |
| `github.com/docker/docker` | Go | From 26.0.0-rc1 | 28.0.0 |
| `github.com/docker/docker` | Go | From 26.0.0-rc1 | 28.0.0 |

Products: Mobyproject Moby.

## How do I fix CVE-2025-54410?

Upgrade github.com/docker/docker to a fixed version for your release line: 25.0.13, 25.0.13+incompatible or 28.0.0.

## Is CVE-2025-54410 being exploited?

There is no known exploitation of CVE-2025-54410 in the wild and no public exploit code.

## Other vulnerabilities in moby

- [CVE-2024-36623](https://insights.sbomify.com/CVE-2024-36623/): Moby Race Condition vulnerability (high 8.1)
- [CVE-2023-28840](https://insights.sbomify.com/CVE-2023-28840/): moby/moby's dockerd daemon encrypted overlay network may be unauthenticated (high 7.5)
- [CVE-2018-12608](https://insights.sbomify.com/CVE-2018-12608/): Docker Authentication Bypass (high 7.5)
- [CVE-2024-24557](https://insights.sbomify.com/CVE-2024-24557/): Moby classic builder cache poisoning (medium 6.9)
- [CVE-2023-28841](https://insights.sbomify.com/CVE-2023-28841/): moby/moby's dockerd daemon encrypted overlay network traffic may be unencrypted (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54410 and fix it if it is affected.

What it is: CVE-2025-54410 is a low-severity missing authorization vulnerability in moby, published on 30 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-54410 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker (Go): affected all versions; fixed in 25.0.13
- github.com/docker/docker (Go): affected all versions; fixed in 25.0.13
- github.com/docker/docker (Go): affected all versions; fixed in 25.0.13+incompatible
- github.com/docker/docker (Go): affected from 26.0.0-rc1; fixed in 28.0.0
- github.com/docker/docker (Go): affected from 26.0.0-rc1; fixed in 28.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54410/ (Markdown: https://insights.sbomify.com/CVE-2025-54410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54410
- OSV: https://osv.dev/vulnerability/CVE-2025-54410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54410/
Summaries are generated and may contain mistakes; the official description above is the record.
