CVE-2025-54412 skops' Inconsistent Trusted Type Validation Enables Hidden `operator` Methods Execution

High 8.7 Published Updated

Attackers can exploit inconsistent type validation in skops to execute arbitrary code via hidden operator methods.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-54412?

CVE-2025-54412 is a high-severity code injection vulnerability in skops-dev skops, published on 26 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

skops is a Python library which helps users share and ship their scikit-learn based models. Versions 0.11.0 and below contain a inconsistency in the OperatorFuncNode which can be exploited to hide the execution of untrusted operator methods. This can then be used in a code reuse attack to invoke seemingly safe functions and escalate to arbitrary code execution with minimal and misleading trusted types. This is fixed in version 0.12.0.

Weakness: CWE-351

Which versions are affected by CVE-2025-54412?

3 open source packages ship an affected version, including skops.

PackageAffectedFixed in
skops PyPIAll versions0.12.0
skops PyPIAll versions0.12.0
skops PyPIAll versions0.12.0

How do I fix CVE-2025-54412?

Upgrade skops to 0.12.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-54412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54412 exists.

Sources

Also known as GHSA-m7f4-hrc6-fwg3, PYSEC-2026-1927.

Is CVE-2025-54412 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free