# CVE-2025-54412: skops' Inconsistent Trusted Type Validation Enables Hidden `operator` Methods Execution

> Attackers can exploit inconsistent type validation in skops to execute arbitrary code via hidden operator methods.

- **Severity:** High 8.7 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-m7f4-hrc6-fwg3, PYSEC-2026-1927

## What is CVE-2025-54412?

CVE-2025-54412 is a high-severity code injection vulnerability in skops-dev skops, published on 26 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

skops is a Python library which helps users share and ship their scikit-learn based models. Versions 0.11.0 and below contain a inconsistency in the OperatorFuncNode which can be exploited to hide the execution of untrusted operator methods. This can then be used in a code reuse attack to invoke seemingly safe functions and escalate to arbitrary code execution with minimal and misleading trusted types. This is fixed in version 0.12.0.

Weakness: CWE-351 (Insufficient Type Distinction)

## Which versions are affected by CVE-2025-54412?

3 open source packages ship an affected version, including skops.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `skops` | PyPI | All versions | 0.12.0 |
| `skops` | PyPI | All versions | 0.12.0 |
| `skops` | PyPI | All versions | 0.12.0 |

## How do I fix CVE-2025-54412?

Upgrade skops to 0.12.0 or later.

## Is CVE-2025-54412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54412 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54412 and fix it if it is affected.

What it is: CVE-2025-54412 is a high-severity code injection vulnerability in skops-dev skops, published on 26 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54412 exists.

Affected packages and fixed versions:
- skops (PyPI): affected all versions; fixed in 0.12.0
- skops (PyPI): affected all versions; fixed in 0.12.0
- skops (PyPI): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54412/ (Markdown: https://insights.sbomify.com/CVE-2025-54412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54412
- OSV: https://osv.dev/vulnerability/CVE-2025-54412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54412/
Summaries are generated and may contain mistakes; the official description above is the record.
