CVE-2025-54413 Skops may allow MethodNode to access unexpected object fields through dot notation, leading to arbitrary code execution at load time
Attackers can achieve arbitrary code execution when loading malicious models due to unsafe dot notation access in skops.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-54413?
CVE-2025-54413 is a high-severity unsafe deserialization vulnerability in skops-dev skops, published on 26 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
skops is a Python library which helps users share and ship their scikit-learn based models. Versions 0.11.0 and below contain an inconsistency in MethodNode, which can be exploited to access unexpected object fields through dot notation. This can be used to achieve arbitrary code execution at load time. While this issue may seem similar to GHSA-m7f4-hrc6-fwg3, it is actually more severe, as it relies on fewer assumptions about trusted types. This is fixed in version 12.0.0.
Weakness: CWE-351
Which versions are affected by CVE-2025-54413?
3 open source packages ship an affected version, including skops.
| Package | Affected | Fixed in |
|---|---|---|
skops PyPI | All versions | 0.12.0 |
skops PyPI | All versions | 0.12.0 |
skops PyPI | All versions | 0.12.0 |
How do I fix CVE-2025-54413?
Upgrade skops to 0.12.0 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-54413 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54413 exists.
Sources
Also known as GHSA-4v6w-xpmh-gfgp, PYSEC-2026-1926.