# CVE-2025-54413: Skops may allow MethodNode to access unexpected object fields through dot notation, leading to arbitrary code execution at load time

> Attackers can achieve arbitrary code execution when loading malicious models due to unsafe dot notation access in skops.

- **Severity:** High 8.7 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-4v6w-xpmh-gfgp, PYSEC-2026-1926

## What is CVE-2025-54413?

CVE-2025-54413 is a high-severity unsafe deserialization vulnerability in skops-dev skops, published on 26 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

skops is a Python library which helps users share and ship their scikit-learn based models. Versions 0.11.0 and below contain an inconsistency in MethodNode, which can be exploited to access unexpected object fields through dot notation. This can be used to achieve arbitrary code execution at load time. While this issue may seem similar to GHSA-m7f4-hrc6-fwg3, it is actually more severe, as it relies on fewer assumptions about trusted types. This is fixed in version 12.0.0.

Weakness: CWE-351 (Insufficient Type Distinction)

## Which versions are affected by CVE-2025-54413?

3 open source packages ship an affected version, including skops.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `skops` | PyPI | All versions | 0.12.0 |
| `skops` | PyPI | All versions | 0.12.0 |
| `skops` | PyPI | All versions | 0.12.0 |

## How do I fix CVE-2025-54413?

Upgrade skops to 0.12.0 or later.

## Is CVE-2025-54413 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54413 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54413 and fix it if it is affected.

What it is: CVE-2025-54413 is a high-severity unsafe deserialization vulnerability in skops-dev skops, published on 26 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54413 exists.

Affected packages and fixed versions:
- skops (PyPI): affected all versions; fixed in 0.12.0
- skops (PyPI): affected all versions; fixed in 0.12.0
- skops (PyPI): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54413/ (Markdown: https://insights.sbomify.com/CVE-2025-54413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54413
- OSV: https://osv.dev/vulnerability/CVE-2025-54413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54413/
Summaries are generated and may contain mistakes; the official description above is the record.
