# CVE-2025-54416: tj-actions/branch-names Contains Command Injection Vulnerability

> Attackers can execute arbitrary commands in downstream workflows via crafted branch names in the tj-actions/branch-names GitHub Action.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-gq52-6phf-x2r6

## What is CVE-2025-54416?

CVE-2025-54416 is a critical command injection vulnerability in tj-actions branch-names, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

tj-actions/branch-names is a Github actions repository that contains workflows to retrieve branch or tag names with support for all events. In versions 8.2.1 and below, a critical vulnerability has been identified in the tj-actions/branch-names' GitHub Action workflow which allows arbitrary command execution in downstream workflows. This issue arises due to inconsistent input sanitization and unescaped output, enabling malicious actors to exploit specially crafted branch names or tags. While internal sanitization mechanisms have been implemented, the action outputs remain vulnerable, exposing consuming workflows to significant security risks. This is fixed in version 9.0.0

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-54416?

1 open source package ship an affected version, including tj-actions/branch-names.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tj-actions/branch-names` | GitHub Actions | All versions | 9.0.0 |

## How do I fix CVE-2025-54416?

Upgrade tj-actions/branch-names to 9.0.0 or later.

## Is CVE-2025-54416 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54416 exists.

Public exploit code:

- PoC for CVE-2025-54416 tj-actions/branch-names command injection (github_poc): https://github.com/HexborneStudio/atlas-tj-actions-poc

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54416 and fix it if it is affected.

What it is: CVE-2025-54416 is a critical command injection vulnerability in tj-actions branch-names, published on 26 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54416 exists.

Affected packages and fixed versions:
- tj-actions/branch-names (GitHub Actions): affected all versions; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54416/ (Markdown: https://insights.sbomify.com/CVE-2025-54416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54416
- OSV: https://osv.dev/vulnerability/CVE-2025-54416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54416/
Summaries are generated and may contain mistakes; the official description above is the record.
