{"answers":{"affected":"4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-54417 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to a fixed version for your release line: 4.16.3 or 5.8.4.","what":"CVE-2025-54417 is a medium-severity command injection vulnerability in Craftcms Craft Cms, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54417 and fix it if it is affected.\n\nWhat it is: CVE-2025-54417 is a medium-severity command injection vulnerability in Craftcms Craft Cms, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54417 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 4.13.8; fixed in 4.16.3\n- craftcms/cms (Packagist): affected from 4.13.8; fixed in 4.16.3\n- craftcms/cms (Packagist): affected from 5.5.8; fixed in 5.8.4\n- craftcms/cms (Packagist): affected from 5.5.8; fixed in 5.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54417/ (Markdown: https://insights.sbomify.com/CVE-2025-54417/index.md)","id":"CVE-2025-54417","markdown":"https://insights.sbomify.com/CVE-2025-54417/index.md","name":"CVE-2025-54417","record":{"aliases":["GHSA-2vcf-qxv3-2mgw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"Attackers with a compromised security key can execute remote CLI commands via the restore-db endpoint in Craft CMS.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"craft_cms","vendor":"craftcms"}],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: \"Craft CMS has a potential RCE with a compromised security key\". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Craft contains a theoretical bypass for CVE-2025-23209","id":"CVE-2025-54417","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"craftcms:craft_cms","products":["craftcms:craft_cms"],"type":"command_injection","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418"},"packages":[{"ecosystem":"Packagist","fixed":["4.16.3"],"introduced":["4.13.8"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-2vcf-qxv3-2mgw"},{"ecosystem":"Packagist","fixed":["4.16.3"],"introduced":["4.13.8"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-2vcf-qxv3-2mgw"},{"ecosystem":"Packagist","fixed":["5.8.4"],"introduced":["5.5.8"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-2vcf-qxv3-2mgw"},{"ecosystem":"Packagist","fixed":["5.8.4"],"introduced":["5.5.8"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-2vcf-qxv3-2mgw"}],"prev":{"headline":"tj-actions/branch-names Contains Command Injection Vulnerability","id":"CVE-2025-54416"},"products":["cms"],"published":"2025-08-09","related":[{"cvss_score":10,"headline":"Craft CMS Code Injection","id":"CVE-2025-32432","kev_date_added":"2026-03-20","published":"2025-04-25"},{"cvss_score":9.3,"headline":"Craft CMS Code Injection","id":"CVE-2024-56145","kev_date_added":"2025-06-02","published":"2024-12-18"},{"cvss_score":8.1,"headline":"Craft CMS Code Injection","id":"CVE-2025-23209","kev_date_added":"2025-02-20","published":"2025-01-18"},{"cvss_score":6.9,"headline":"Craft CMS External Control of Assumed-Immutable Web Parameter","id":"CVE-2025-35939","kev_date_added":"2025-06-02","published":"2025-05-07"},{"cvss_score":10,"headline":"Craft CMS Remote Code Execution vulnerability","id":"CVE-2023-41892","kev_date_added":null,"published":"2023-09-13"},{"cvss_score":9.8,"headline":"Craft CMS Remote Code Injection","id":"CVE-2021-27903","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9.8,"headline":"SEOmatic for CraftCMS allows Server-Side Template Injection","id":"CVE-2020-9757","kev_date_added":null,"published":"2020-03-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-11","vendors":["craftcms"]},"summary":"Attackers with a compromised security key can execute remote CLI commands via the restore-db endpoint in Craft CMS.","url":"https://insights.sbomify.com/CVE-2025-54417/"}