# CVE-2025-54417: Craft contains a theoretical bypass for CVE-2025-23209

> Attackers with a compromised security key can execute remote CLI commands via the restore-db endpoint in Craft CMS.

- **Severity:** Medium 5.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** GHSA-2vcf-qxv3-2mgw

## What is CVE-2025-54417?

CVE-2025-54417 is a medium-severity command injection vulnerability in Craftcms Craft Cms, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-54417?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.13.8 | 4.16.3 |
| `craftcms/cms` | Packagist | From 4.13.8 | 4.16.3 |
| `craftcms/cms` | Packagist | From 5.5.8 | 5.8.4 |
| `craftcms/cms` | Packagist | From 5.5.8 | 5.8.4 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2025-54417?

Upgrade craftcms/cms to a fixed version for your release line: 4.16.3 or 5.8.4.

## Is CVE-2025-54417 being exploited?

There is no known exploitation of CVE-2025-54417 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54417 and fix it if it is affected.

What it is: CVE-2025-54417 is a medium-severity command injection vulnerability in Craftcms Craft Cms, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54417 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.13.8; fixed in 4.16.3
- craftcms/cms (Packagist): affected from 4.13.8; fixed in 4.16.3
- craftcms/cms (Packagist): affected from 5.5.8; fixed in 5.8.4
- craftcms/cms (Packagist): affected from 5.5.8; fixed in 5.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54417/ (Markdown: https://insights.sbomify.com/CVE-2025-54417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54417
- OSV: https://osv.dev/vulnerability/CVE-2025-54417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54417/
Summaries are generated and may contain mistakes; the official description above is the record.
