{"answers":{"affected":"2 open source packages ship an affected version, including codeigniter4/framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-54418 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.6.2 or later.","what":"CVE-2025-54418 is a critical command injection vulnerability in CodeIgniter4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54418 and fix it if it is affected.\n\nWhat it is: CVE-2025-54418 is a critical command injection vulnerability in CodeIgniter4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.6.2\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54418/ (Markdown: https://insights.sbomify.com/CVE-2025-54418/index.md)","id":"CVE-2025-54418","markdown":"https://insights.sbomify.com/CVE-2025-54418/index.md","name":"CVE-2025-54418","record":{"aliases":["GHSA-9952-gv64-x94c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary commands via malicious filenames or text inputs when using the ImageMagick handler in CodeIgniter4.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"CodeIgniter is a PHP full-stack web framework. A command injection vulnerability present in versions prior to 4.6.2 affects applications that use the ImageMagick handler for image processing (`imagick` as the image library) and either allow file uploads with user-controlled filenames and process uploaded images using the `resize()` method or use the `text()` method with user-controlled text content or options. An attacker can upload a file with a malicious filename containing shell metacharacters that get executed when the image is processed or provide malicious text content or options that get executed when adding text to images Users should upgrade to v4.6.2 or later to receive a patch. As a workaround, switch to the GD image handler (`gd`, the default handler), which is not affected by either vulnerability. For file upload scenarios, instead of using user-provided filenames, generate random names to eliminate the attack vector with `getRandomName()` when using the `move()` method, or use the `store()` method, which automatically generates safe filenames. For text operations, if one must use ImageMagick with user-controlled text, sanitize the input to only allow safe characters and validate/restrict text options.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Node-SAML Contains SAML Signature Verification Vulnerability","id":"CVE-2025-54419"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.2"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-9952-gv64-x94c"},{"ecosystem":"Packagist","fixed":["4.6.2"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-9952-gv64-x94c"}],"prev":{"headline":"Craft contains a theoretical bypass for CVE-2025-23209","id":"CVE-2025-54417"},"products":["CodeIgniter4"],"published":"2025-07-28","related":[{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-28","vendors":["codeigniter4"]},"summary":"Attackers can execute arbitrary commands via malicious filenames or text inputs when using the ImageMagick handler in CodeIgniter4.","url":"https://insights.sbomify.com/CVE-2025-54418/"}