# CVE-2025-54418: CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability

> Attackers can execute arbitrary commands via malicious filenames or text inputs when using the ImageMagick handler in CodeIgniter4.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-9952-gv64-x94c

## What is CVE-2025-54418?

CVE-2025-54418 is a critical command injection vulnerability in CodeIgniter4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. A command injection vulnerability present in versions prior to 4.6.2 affects applications that use the ImageMagick handler for image processing (`imagick` as the image library) and either allow file uploads with user-controlled filenames and process uploaded images using the `resize()` method or use the `text()` method with user-controlled text content or options. An attacker can upload a file with a malicious filename containing shell metacharacters that get executed when the image is processed or provide malicious text content or options that get executed when adding text to images Users should upgrade to v4.6.2 or later to receive a patch. As a workaround, switch to the GD image handler (`gd`, the default handler), which is not affected by either vulnerability. For file upload scenarios, instead of using user-provided filenames, generate random names to eliminate the attack vector with `getRandomName()` when using the `move()` method, or use the `store()` method, which automatically generates safe filenames. For text operations, if one must use ImageMagick with user-controlled text, sanitize the input to only allow safe characters and validate/restrict text options.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-54418?

2 open source packages ship an affected version, including codeigniter4/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.6.2 |
| `codeigniter4/framework` | Packagist | All versions | 4.6.2 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2025-54418?

Upgrade codeigniter4/framework to 4.6.2 or later.

## Is CVE-2025-54418 being exploited?

There is no known exploitation of CVE-2025-54418 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40827](https://insights.sbomify.com/CVE-2022-40827/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54418 and fix it if it is affected.

What it is: CVE-2025-54418 is a critical command injection vulnerability in CodeIgniter4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54418 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.6.2
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54418/ (Markdown: https://insights.sbomify.com/CVE-2025-54418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54418
- OSV: https://osv.dev/vulnerability/CVE-2025-54418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54418/
Summaries are generated and may contain mistakes; the official description above is the record.
