{"answers":{"affected":"6 open source packages ship an affected version, including @node-saml/node-saml, @node-saml/passport-saml and passport-saml.","exploited":"There is no known exploitation of CVE-2025-54419 in the wild and no public exploit code.","fix":"Upgrade @node-saml/node-saml to 5.1.0 or later.","what":"CVE-2025-54419 is a critical authentication bypass vulnerability in node-saml, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54419 and fix it if it is affected.\n\nWhat it is: CVE-2025-54419 is a critical authentication bypass vulnerability in node-saml, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54419 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @node-saml/node-saml (npm): affected all versions; fixed in 5.1.0\n- @node-saml/node-saml (npm): affected all versions; fixed in 5.1.0\n- @node-saml/passport-saml (npm): affected all versions; fixed in 5.1.0\n- @node-saml/passport-saml (npm): affected all versions; fixed in 5.1.0\n- passport-saml (npm): affected all versions up to 3.2.4; no fix listed\n- passport-saml (npm): affected all versions up to 3.2.4; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54419/ (Markdown: https://insights.sbomify.com/CVE-2025-54419/index.md)","id":"CVE-2025-54419","markdown":"https://insights.sbomify.com/CVE-2025-54419/index.md","name":"CVE-2025-54419","record":{"aliases":["GHSA-4mxg-3p6v-xgq3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SAML library","requires_auth":"none","summary":"Attackers can modify authentication details in valid SAML assertions by exploiting signature verification flaws, potentially leading to unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"A SAML library not dependent on any frameworks that runs in Node. In version 5.0.1, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. To conduct the attack an attacker would need a validly signed document from the identity provider (IdP). This is fixed in version 5.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Node-SAML Contains SAML Signature Verification Vulnerability","id":"CVE-2025-54419","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":6,"n_references":3,"next":{"headline":"NamelessMC allows Stored Cross Site Scripting (XSS) in SEO component","id":"CVE-2025-54421"},"packages":[{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"@node-saml/node-saml","purl":null,"source":"GHSA-4mxg-3p6v-xgq3"},{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"@node-saml/node-saml","purl":"pkg:npm/%40node-saml/node-saml","source":"GHSA-4mxg-3p6v-xgq3"},{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"@node-saml/passport-saml","purl":null,"source":"GHSA-4mxg-3p6v-xgq3"},{"ecosystem":"npm","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"@node-saml/passport-saml","purl":"pkg:npm/%40node-saml/passport-saml","source":"GHSA-4mxg-3p6v-xgq3"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.2.4"],"package":"passport-saml","purl":null,"source":"GHSA-4mxg-3p6v-xgq3"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["3.2.4"],"package":"passport-saml","purl":"pkg:npm/passport-saml","source":"GHSA-4mxg-3p6v-xgq3"}],"prev":{"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418"},"products":["node-saml"],"published":"2025-07-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-28","vendors":["node-saml"]},"summary":"Attackers can modify authentication details in valid SAML assertions by exploiting signature verification flaws, potentially leading to unauthorized access.","url":"https://insights.sbomify.com/CVE-2025-54419/"}