# CVE-2025-54422: Sandboxie exposes encrypted sandbox key during password change

> An attacker can intercept sandbox passwords via command-line arguments during password changes, exposing credentials to any process in the user session.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Jul 2025
- **Updated:** 29 Jul 2025
- **Also known as:** GHSA-jp7r-vgv9-43p7

## What is CVE-2025-54422?

CVE-2025-54422 is a medium-severity vulnerability in sandboxie-plus Sandboxie, published on 29 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Sandboxie is a sandbox-based isolation software for 32-bit and 64-bit Windows NT-based operating systems. In versions 1.16.1 and below, a critical security vulnerability exists in password handling mechanisms. During encrypted sandbox creation, user passwords are transmitted via shared memory, exposing them to potential interception. The vulnerability is particularly severe during password modification operations, where both old and new passwords are passed as plaintext command-line arguments to the Imbox process without any encryption or obfuscation. This implementation flaw allows any process within the user session, including unprivileged processes, to retrieve these sensitive credentials by reading the command-line arguments, thereby bypassing standard privilege requirements and creating a significant security risk. This is fixed in version 1.16.2.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere), CWE-322 (Key Exchange without Entity Authentication), CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2025-54422?

It affects 1 product.


Products: Sandboxie-Plus Sandboxie.

## How do I fix CVE-2025-54422?

No fix has been published for CVE-2025-54422 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54422 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54422 exists.

## Other vulnerabilities in sandboxie-plus Sandboxie

- [CVE-2018-18748](https://insights.sbomify.com/CVE-2018-18748/): Security feature bypass in n/a (critical 10.0)
- [CVE-2025-64721](https://insights.sbomify.com/CVE-2025-64721/): Sandboxie's Integer Overflow in SbieIniServer::RC4Crypt allows sandbox escape and SYSTEM compromise (critical 9.9)
- [CVE-2026-34458](https://insights.sbomify.com/CVE-2026-34458/): Sandboxie-Plus privilege escalation via INI CRLF injection bypassing EditAdminOnly (critical 9.3)
- [CVE-2024-49360](https://insights.sbomify.com/CVE-2024-49360/): Path traversal in Sandboxie (critical 9.2)
- [CVE-2026-34459](https://insights.sbomify.com/CVE-2026-34459/): Sandboxie-Plus sandbox escape via uninitialized memory leak and stack overflow in GetRawInputDeviceInfoSlave (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54422 and fix it if it is affected.

What it is: CVE-2025-54422 is a medium-severity vulnerability in sandboxie-plus Sandboxie, published on 29 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54422 exists.

Affected product: sandboxie-plus Sandboxie. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54422/ (Markdown: https://insights.sbomify.com/CVE-2025-54422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54422
- OSV: https://osv.dev/vulnerability/CVE-2025-54422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54422/
Summaries are generated and may contain mistakes; the official description above is the record.
