CVE-2025-54424 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution
Attackers can bypass certificate verification to access privileged interfaces and execute arbitrary commands on Linux servers managed by 1Panel.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54424?
CVE-2025-54424 is a high-severity vulnerability in 1Panel-dev 1Panel, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
1Panel is a web interface and MCP Server that manages websites, files, containers, databases, and LLMs on a Linux server. In versions 2.0.5 and below, the HTTPS protocol used for communication between the Core and Agent endpoints has incomplete certificate verification during certificate validation, leading to unauthorized interface access. Due to the presence of numerous command execution or high-privilege interfaces in 1Panel, this results in Remote Code Execution (RCE). This is fixed in version 2.0.6. The CVE has been translated from Simplified Chinese using GitHub Copilot.
Weakness: CWE-77
Which versions are affected by CVE-2025-54424?
5 open source packages ship an affected version, including github.com/1Panel-dev/1Panel/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/1Panel-dev/1Panel/core Go | All versions | None |
github.com/1Panel-dev/1Panel/core Go | All versions | 0.0.0-20250730021757-04b9cbd87a15 |
github.com/1Panel-dev/1Panel/core Go | All versions | 0.0.0-20250730021757-04b9cbd87a15 |
github.com/1Panel-dev/1Panel/core Go | From 1.0.0 | 2.0.6 |
github.com/1Panel-dev/1Panel/core Go | From 1.0.0 | 2.0.6 |
Products include Fit2cloud 1panel.
How do I fix CVE-2025-54424?
Upgrade github.com/1Panel-dev/1Panel/core to a fixed version for your release line: 0.0.0-20250730021757-04b9cbd87a15 or 2.0.6.
Is CVE-2025-54424 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54424 exists.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in 1Panel-dev 1Panel
Sources
Also known as GHSA-8j63-96wh-wh3j, GO-2025-3834.