# CVE-2025-54424: 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution

> Attackers can bypass certificate verification to access privileged interfaces and execute arbitrary commands on Linux servers managed by 1Panel.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 4 Aug 2025
- **Also known as:** GHSA-8j63-96wh-wh3j, GO-2025-3834

## What is CVE-2025-54424?

CVE-2025-54424 is a high-severity vulnerability in 1Panel-dev 1Panel, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

1Panel is a web interface and MCP Server that manages websites, files, containers, databases, and LLMs on a Linux server. In versions 2.0.5 and below, the HTTPS protocol used for communication between the Core and Agent endpoints has incomplete certificate verification during certificate validation, leading to unauthorized interface access. Due to the presence of numerous command execution or high-privilege interfaces in 1Panel, this results in Remote Code Execution (RCE). This is fixed in version 2.0.6. The CVE has been translated from Simplified Chinese using GitHub Copilot.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-54424?

5 open source packages ship an affected version, including github.com/1Panel-dev/1Panel/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel/core` | Go | All versions | None |
| `github.com/1Panel-dev/1Panel/core` | Go | All versions | 0.0.0-20250730021757-04b9cbd87a15 |
| `github.com/1Panel-dev/1Panel/core` | Go | All versions | 0.0.0-20250730021757-04b9cbd87a15 |
| `github.com/1Panel-dev/1Panel/core` | Go | From 1.0.0 | 2.0.6 |
| `github.com/1Panel-dev/1Panel/core` | Go | From 1.0.0 | 2.0.6 |

Products: Fit2cloud 1panel.

## How do I fix CVE-2025-54424?

Upgrade github.com/1Panel-dev/1Panel/core to a fixed version for your release line: 0.0.0-20250730021757-04b9cbd87a15 or 2.0.6.

## Is CVE-2025-54424 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54424 exists.

Public exploit code:

- CVE-2025-54424：1Panel 客户端证书绕过RCE漏洞 一体化工具 (扫描+利用) (github_poc): https://github.com/Mr-xn/CVE-2025-54424
- CVE-2025-54424: 1Panel TLS client cert bypass enables RCE via forged CN 'panel_client' using a bundled scanning and exploitation tool. Affected: <= v2.0.5. 🔐 (github_poc): https://github.com/hophtien/CVE-2025-54424
- https://github.com/anonnymous5/1Panel-CVE-2025-54424- (github_poc): https://github.com/anonnymous5/1Panel-CVE-2025-54424-

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)
- [CVE-2023-39964](https://insights.sbomify.com/CVE-2023-39964/): 1Panel O&M management panel has a background arbitrary file reading vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54424 and fix it if it is affected.

What it is: CVE-2025-54424 is a high-severity vulnerability in 1Panel-dev 1Panel, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54424 exists.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel/core (Go): affected all versions; no fix listed
- github.com/1Panel-dev/1Panel/core (Go): affected all versions; fixed in 0.0.0-20250730021757-04b9cbd87a15
- github.com/1Panel-dev/1Panel/core (Go): affected all versions; fixed in 0.0.0-20250730021757-04b9cbd87a15
- github.com/1Panel-dev/1Panel/core (Go): affected from 1.0.0; fixed in 2.0.6
- github.com/1Panel-dev/1Panel/core (Go): affected from 1.0.0; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54424/ (Markdown: https://insights.sbomify.com/CVE-2025-54424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54424
- OSV: https://osv.dev/vulnerability/CVE-2025-54424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54424/
Summaries are generated and may contain mistakes; the official description above is the record.
