# CVE-2025-54428: RevelaCode exposes Sensitive MongoDB Atlas URI in .env (potential credential leak)

> Attackers can access production databases by using hardcoded MongoDB credentials exposed in the public repository, leading to data theft or modification.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-m253-qvcr-cr48

## What is CVE-2025-54428?

CVE-2025-54428 is a critical vulnerability in musombi123 RevelaCode-Backend, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RevelaCode is an AI-powered faith-tech project that decodes biblical verses, prophecies and global events into accessible language. In versions below 1.0.1, a valid MongoDB Atlas URI with embedded username and password was accidentally committed to the public repository. This could allow unauthorized access to production or staging databases, potentially leading to data exfiltration, modification, or deletion. This is fixed in version 1.0.1. Workarounds include: immediately rotating credentials for the exposed database user, using a secret manager (like Vault, Doppler, AWS Secrets Manager, etc.) instead of storing secrets directly in code, or auditing recent access logs for suspicious activity.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-54428?


## How do I fix CVE-2025-54428?

No fix has been published for CVE-2025-54428 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54428 being exploited?

There is no known exploitation of CVE-2025-54428 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54428 and fix it if it is affected.

What it is: CVE-2025-54428 is a critical vulnerability in musombi123 RevelaCode-Backend, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54428 in the wild and no public exploit code.

Affected product: musombi123 RevelaCode-Backend. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54428/ (Markdown: https://insights.sbomify.com/CVE-2025-54428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54428
- OSV: https://osv.dev/vulnerability/CVE-2025-54428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54428/
Summaries are generated and may contain mistakes; the official description above is the record.
