# CVE-2025-54433: Bugsink is vulnerable to Path Traversal attacks via event_id in ingestion

> Attackers with valid DSN access can overwrite or create arbitrary files via path traversal in event_id, potentially compromising the host system.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** GHSA-q78p-g86f-jg6q, PYSEC-2026-1226

## What is CVE-2025-54433?

CVE-2025-54433 is a high-severity path traversal vulnerability in bugsink, published on 30 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bugsink is a self-hosted error tracking service. In versions 1.4.2 and below, 1.5.0 through 1.5.4, 1.6.0 through 1.6.3, and 1.7.0 through 1.7.3,  ingestion paths construct file locations directly from untrusted event_id input without validation. A specially crafted event_id can result in paths outside the intended directory, potentially allowing file overwrite or creation in arbitrary locations. Submitting such input requires access to a valid DSN, potentially exposing them. If Bugsink runs in a container, the effect is confined to the container’s filesystem. In non-containerized setups, the overwrite may affect other parts of the system accessible to that user. This is fixed in versions 1.4.3, 1.5.5, 1.6.4 and 1.7.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-54433?

9 open source packages ship an affected version, including bugsink.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | All versions | 1.4.3, 1.5.5, 1.6.4, 1.7.4, 1.6.4 |
| `bugsink` | PyPI | All versions | 1.4.3 |
| `bugsink` | PyPI | All versions | 1.4.3 |
| `bugsink` | PyPI | From 1.5.0 | 1.5.5 |
| `bugsink` | PyPI | From 1.5.0 | 1.5.5 |
| `bugsink` | PyPI | From 1.6.0 | 1.6.4 |
| `bugsink` | PyPI | From 1.6.0 | 1.6.4 |
| `bugsink` | PyPI | From 1.7.0 | 1.7.4 |
| `bugsink` | PyPI | From 1.7.0 | 1.7.4 |

## How do I fix CVE-2025-54433?

Upgrade bugsink to a fixed version for your release line: 1.4.3, 1.5.5, 1.6.4 or 1.7.4.

## Is CVE-2025-54433 being exploited?

There is no known exploitation of CVE-2025-54433 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54433 and fix it if it is affected.

What it is: CVE-2025-54433 is a high-severity path traversal vulnerability in bugsink, published on 30 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54433 in the wild and no public exploit code.

Affected packages and fixed versions:
- bugsink (PyPI): affected all versions; fixed in 1.4.3, 1.5.5, 1.6.4, 1.7.4, 1.6.4
- bugsink (PyPI): affected all versions; fixed in 1.4.3
- bugsink (PyPI): affected all versions; fixed in 1.4.3
- bugsink (PyPI): affected from 1.5.0; fixed in 1.5.5
- bugsink (PyPI): affected from 1.5.0; fixed in 1.5.5
- bugsink (PyPI): affected from 1.6.0; fixed in 1.6.4
- bugsink (PyPI): affected from 1.6.0; fixed in 1.6.4
- bugsink (PyPI): affected from 1.7.0; fixed in 1.7.4
- bugsink (PyPI): affected from 1.7.0; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54433/ (Markdown: https://insights.sbomify.com/CVE-2025-54433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54433
- OSV: https://osv.dev/vulnerability/CVE-2025-54433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54433/
Summaries are generated and may contain mistakes; the official description above is the record.
