# CVE-2025-54472: Apache bRPC: Redis Parser Remote Denial of Service

> Attackers can crash Apache bRPC services by sending malicious Redis protocol packets that trigger excessive memory allocation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-fgf7-x5pv-vcc3

## What is CVE-2025-54472?

CVE-2025-54472 is a high-severity denial of service vulnerability in Apache bRPC, published on 14 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unlimited memory allocation in redis protocol parser in Apache bRPC (all versions < 1.14.1) on all platforms allows attackers to crash the service via network.

Root Cause: In the bRPC Redis protocol parser code, memory for arrays or strings of corresponding sizes is allocated based on the integers read from the network. If the integer read from the network is too large, it may cause a bad alloc error and lead to the program crashing. Attackers can exploit this feature by sending special data packets to the bRPC service to carry out a denial-of-service attack on it.
The bRPC 1.14.0 version tried to fix this issue by limited the memory allocation size, however, the limitation checking code is not well implemented that may cause integer overflow and evade such limitation. So the 1.14.0 version is also vulnerable, although the integer range that affect version 1.14.0 is different from that affect version < 1.14.0.

Affected scenarios: Using bRPC as a Redis server to provide network services to untrusted clients, or using bRPC as a Redis client to call untrusted Redis services.

How to Fix: we provide two methods, you can choose one of them:

1. Upgrade bRPC to version 1.14.1.
2. Apply this patch ( https://github.com/apache/brpc/pull/3050 ) manually.

No matter you choose which method, you should note that the patch limits the maximum length of memory allocated for each time in the bRPC Redis parser. The default limit is 64M. If some of you redis request or response have a size larger than 64M, you might encounter error after upgrade. For such case, you can modify the gflag redis_max_allocation_size to set a larger limit.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2025-54472?

It affects 1 product.


Products: Apache Brpc.

## How do I fix CVE-2025-54472?

No fix has been published for CVE-2025-54472 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54472 being exploited?

There is no known exploitation of CVE-2025-54472 in the wild and no public exploit code.

## Other vulnerabilities in Apache bRPC

- [CVE-2025-60021](https://insights.sbomify.com/CVE-2025-60021/): Apache bRPC: Remote command injection vulnerability in heap builtin service (critical 9.8)
- [CVE-2023-31039](https://insights.sbomify.com/CVE-2023-31039/): Apache bRPC: ServerOptions.pid_file may cause arbitrary code execution (critical 9.8)
- [CVE-2025-59789](https://insights.sbomify.com/CVE-2025-59789/): Apache bRPC: Stack Exhaustion via Unbounded Recursion in JSON Parser (high 7.5)
- [CVE-2024-23452](https://insights.sbomify.com/CVE-2024-23452/): Apache bRPC: HTTP request smuggling vulnerability (high 7.5)
- [CVE-2023-45757](https://insights.sbomify.com/CVE-2023-45757/): Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54472 and fix it if it is affected.

What it is: CVE-2025-54472 is a high-severity denial of service vulnerability in Apache bRPC, published on 14 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54472 in the wild and no public exploit code.

Affected product: Apache bRPC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54472/ (Markdown: https://insights.sbomify.com/CVE-2025-54472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54472
- OSV: https://osv.dev/vulnerability/CVE-2025-54472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54472/
Summaries are generated and may contain mistakes; the official description above is the record.
