CVE-2025-54499 Insecure string comparison enables timing attacks
Attackers can exploit timing oracles to brute-force Cloud API keys and OAuth client secrets, leading to credential disclosure and potential account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54499?
CVE-2025-54499 is a low-severity vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.10, 10.11.x <= 10.11.2 fail to use constant-time comparison for sensitive string comparisons which allows attackers to exploit timing oracles to perform byte-by-byte brute force attacks via response time analysis on Cloud API keys and OAuth client secrets
Weakness: CWE-208
Which versions are affected by CVE-2025-54499?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.3 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.3 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.11 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.11 |
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.11+incompatible, 10.11.3+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
4 more packages
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250728063359-38208b8f065f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250728063359-38208b8f065f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250728063359-38208b8f065f |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-54499?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.3, 10.5.11, 10.5.11+incompatible or 10.11.3+incompatible.
Is CVE-2025-54499 being exploited?
There is no known exploitation of CVE-2025-54499 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-xr3w-rmvj-f6m7, GO-2025-4036.