{"answers":{"affected":"3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-confluence. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-54525 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-plugin-confluence to 1.5.0 or later.","what":"CVE-2025-54525 is a high-severity denial of service vulnerability in Mattermost Confluence Plugin, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54525 and fix it if it is affected.\n\nWhat it is: CVE-2025-54525 is a high-severity denial of service vulnerability in Mattermost Confluence Plugin, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-54525 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54525/ (Markdown: https://insights.sbomify.com/CVE-2025-54525/index.md)","id":"CVE-2025-54525","markdown":"https://insights.sbomify.com/CVE-2025-54525/index.md","name":"CVE-2025-54525","record":{"aliases":["GHSA-3cg3-3mmr-w8hj","GO-2025-3872"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Confluence Plugin","requires_auth":"none","summary":"Attackers can crash the Mattermost Confluence Plugin by sending invalid request bodies to the channel subscription endpoint, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"confluence","vendor":"mattermost"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1287","name":"Improper Validation of Specified Type of Input"}],"description":"Mattermost Confluence Plugin version \u003c1.5.0 fails to handle unexpected request body which allows attackers to crash the plugin via constant hit to create channel subscription endpoint with an invalid request body.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unexpected input to Create Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-54525","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Fuji Electric Monitouch V-SFT-6 Stack-based Buffer Overflow","id":"CVE-2025-54526"},"packages":[{"ecosystem":"Go","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":null,"source":"GHSA-3cg3-3mmr-w8hj"},{"ecosystem":"Go","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-confluence","source":"GHSA-3cg3-3mmr-w8hj"},{"ecosystem":"Go","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-confluence","source":"GO-2025-3872"}],"prev":{"headline":"Security feature bypass in Artix™ 7-Series FPGA","id":"CVE-2025-54520"},"products":["Mattermost Confluence Plugin"],"published":"2025-08-11","related":[{"cvss_score":7.7,"headline":"Cross-Site Scripting (XSS) via Unescaped Display Names in Mattermost Confluence Plugin OAuth2 Flow","id":"CVE-2025-13523","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":7.5,"headline":"Unexpected input to Update Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-52931","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.2,"headline":"Unauthenticated Channel Subscription Creation in Mattermost Confluence Plugin","id":"CVE-2025-44004","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.2,"headline":"Unauthenticated Channel Subscription Edit in Mattermost Confluence Plugin","id":"CVE-2025-54478","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":6.4,"headline":"Unauthorized Subscription Edit to Confluence Space in Mattermost Confluence Plugin","id":"CVE-2025-48731","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":5.9,"headline":"Unexpected Input to Server Webhook endpoint Causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-53514","kev_date_added":null,"published":"2025-08-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-11","vendors":["Mattermost"]},"summary":"Attackers can crash the Mattermost Confluence Plugin by sending invalid request bodies to the channel subscription endpoint, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2025-54525/"}